Intermittent TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_videocontrols.html | Exited with code 1 during test run

RESOLVED DUPLICATE of bug 729126

Status

()

defect
RESOLVED DUPLICATE of bug 729126
8 years ago
8 years ago

People

(Reporter: jaws, Unassigned)

Tracking

({crash})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

###!!! ABORT: unexpected unit 1, from 1 and 1: 'false', file ../../../layout/style/nsStyleAnimation.cpp, line 888
TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_videocontrols.html | Exited with code 1 during test run
INFO | automation.py | Application ran for: 0:05:51.385362
INFO | automation.py | Reading PID log: /tmp/tmpzG7HR1pidlog
PROCESS-CRASH | /tests/toolkit/content/tests/widgets/test_videocontrols.html | application crashed (minidump found)


This started showing up with the patch from bug 722258 but I think that's just because the video controls test wasn't using the animation until now. Bug 666306 introduced the large overlay button.
We should be prepared to back out bug 666306 if we can't find a fix for this by March 13 when the patch that introduced this will be merged from Aurora to Beta.
David, this assertion is being hit with the large play button on the video controls when the background size is transitioned from |64px, 64px| to |192px, 192px|. Should this assert be fatal? How could this cause a transition from 1 to 1?

http://hg.mozilla.org/mozilla-central/annotate/afc1125f9c14/layout/style/nsStyleAnimation.cpp#l984

http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/winstripe/global/media/videocontrols.css#250
Marcia, do you know of any crashes in the wild due to this?
Not sure what tree comment 0 was from, but that wouldn't happen once you have the fix.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 729126
Thanks! This is in fx-team repository by the way.
You need to log in before you can comment on or make changes to this bug.