If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

app freezes in mail send

VERIFIED DUPLICATE of bug 65703

Status

MailNews Core
Networking
--
major
VERIFIED DUPLICATE of bug 65703
17 years ago
9 years ago

People

(Reporter: tracy, Assigned: John G. Myers)

Tracking

({smoketest})

Trunk
PowerPC
Mac System 9.x
smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
seen on mac commercial build 2001-03-22-04-trunk

-compose a mail massage (pop imap plain text html it doesn't matter)

app freezes.
(Reporter)

Updated

17 years ago
Keywords: smoketest

Updated

17 years ago
QA Contact: esther → sheelar

Comment 1

17 years ago
possibly related to sending regressions from the xul syntax changes? 73028?

Comment 2

17 years ago
What is the status of this bug?  Has it been fixed with other fixes?  Is it only 
a problem on Mac?
Hardware: PC → Macintosh

Comment 3

17 years ago
I'm hoping it's a dup of the compose window xul syntax change horkage. 

Comment 4

17 years ago
the only changes in mailnews\compose yesterday was the xul syntax change.
Nothing else (i.e. in the smtp protocol or elsewhere) has changed.

Comment 5

17 years ago
Scott--are you verifying that this is a duplicate now in your own tree or ?

Comment 6

17 years ago
i believe this was related to all the other send problems we had today. 

*** This bug has been marked as a duplicate of 73028 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

17 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 7

17 years ago
reopening.....I see this mac commercal build 2001-03-23-04-trunk

I can't test the bug this was duped against for that was a windows bug and the 
windows build is hosed this morning
When exactly the App Freeze? During the opening of the compose window or during the send? If it's during the send, 
what'is the last status text on the Mail3Pane Window status bar?
also encountered this while going thru bug 73048.

Macsbug trace info, fwiw...

 (CurStackBase does not seem to apply...dumping 4K.)
  Calling chain using A6/R1 links
  Back chain  ISA  Caller
  055A97F9    PPC  003DF32C  EmToNatEndMoveParams+00014
  055A9780    PPC  0035524C  
  055A9730    PPC  011802C8  
  055A9638    68K  00388CFE  'scod BFAF 0002'+01F1E
  055A9610    68K  0038D096  'scod BFAF 0002'+062B6
  055A95FC    68K  003988B8  'scod BFAF 0002'+11AD8
 (CurStackBase does not seem to apply...dumping 4K.)
  Return addresses on the stack
  Stack Addr  Frame Addr   ISA   Caller
   055AA0EE                68K   01282BFE
   055A9B3C                PPC   06B4895C PR_GetThreadPrivate+004F4
   055A9998    055A9990    PPC   06B4A3F4 PRP_TryLock+00994
   055A9938    055A9930    PPC   06B48940 PR_GetThreadPrivate+004D8
   055A98E8    055A98E0    PPC   06B4EF90 PR_GetPrimaryThread+002A0
   055A98D8    055A98D0    PPC   06B48DEC _PR_GetPrimordialCPU+0045C
   055A98C8                68K   0561F36E
   055A98B4    055A98B0    68K   00075062
   055A98A8    055A98A0    PPC   FFD0133C WaitNextEvent+00028
   055A9828    055A9820    PPC   06B4FAD8 PR_LocalTimeParameters+0019C
   055A97F4    055A97F0    68K   00A41F5E
   055A9788                PPC   003DF32C EmToNatEndMoveParams+00014
   055A9738    055A9730    PPC   0035524C
   055A96F8    055A96F0    PPC   00357054 MPGetPoolStatistics+002A0
   055A96E8    055A96E0    PPC   011802C8
   055A9684                PPC   055A971C js_EmitTree+01E84
   055A9614    055A9610    68K   00388CFE 'scod BFAF 0002'+01F1E
   055A9600    055A95FC    68K   0038D096 'scod BFAF 0002'+062B6
   055A95F0    055A95EC    68K   003988B8 'scod BFAF 0002'+11AD8
   055A95D0    055A95CC    68K   00398966 'scod BFAF 0002'+11B86
   055A95C2                68K   00630558
   055A95B8                68K   075BFFFE
 Closing log
(Reporter)

Comment 10

17 years ago
it freezes the instant you click on "Send"

I don't see any status changes.  just says done loading page...like ti did when 
the mail compose window completed opening

Comment 11

17 years ago
ok, sounds like the problem is happening before the smtp layer. re-assigning to
Jean-Francois. sorry jf =(.
Assignee: mscott → ducarroz
Status: REOPENED → NEW

Comment 12

17 years ago
Who is Jean-Francois? I couldn't find Jean-Francois in the pb so can't contact 
this person.  Also you should change the owner of this bug to the new person.
Thanks.  Loan
it' me :-), I am working at home today. You can find my phone number in the pb
Status: NEW → ASSIGNED
I made a socket changed yesterday that the mail tranport code uses.  Try backing that out of your mac build and see if it helps.  I seriously doubt it but it might be.
Looks like the crah appear right at the beginnig in the JS script. Therefore is way before we start any network 
operation. I suspect an XPConnect problem!
Tracy:

If I am right, the message compose window still up when you freeze?
what's append if you try to save the message instead of sending it?
can you try to send a message with a new profile?

My Debug build from this morning works perfectly as was my build yesterday.
(Reporter)

Comment 17

17 years ago
when using a new profile the compose window goes away but then the app 
immediately freezes...the message is not sent.

save does nothing:  no dialogue comes up asking where to save(I suppose that is 
what would happen)

Comment 18

17 years ago
Using the same build on Mac 9.0.4 I am able to save the message as draft,
template or as a file.  Draft, template is going to my local sent folder.  The
dialog to save did come up and I successfully saved the message. It was a plain
text message from the html compose window.  I also could save the message to
draft from the toolbar save. 
I found something, let me do some more test to be sure it's the problem...
He is what I have found:

the function nsMsgCompose::SendMsg now has two arguments, use to have 3 before the branch landing. Looks like we 
missed to remove the extra argument in MsgComposeCommands.js when we merge the branch before landing. This 
seems to have some wierd side effect. But when I remove the extra argument, XPConnect now complains that we are 
missing one!!! despite the IDL definition is correct!
after trashing my xpt file and rebuilding it, everything works again for me. I hoppe that's the real problem!
I am not sure 100% that's the solution to the crash as I am not able to reproduce it but it's definitively something 
we must fix:

Index: mozilla/mailnews/compose/resources/content/MsgComposeCommands.js
===================================================================
RCS file: /cvsroot/mozilla/mailnews/compose/resources/content/MsgComposeCommands.js,v
retrieving revision 1.154
diff -w -b -u -2 -r1.154 MsgComposeCommands.js
--- MsgComposeCommands.js	2001/03/22 07:24:56	1.154
+++ MsgComposeCommands.js	2001/03/23 23:51:13
@@ -1101,10 +1101,10 @@
 			  windowLocked = true;
 			  CommandUpdate_MsgCompose();
-				msgCompose.SendMsg(msgType, getCurrentIdentity(), null);
+				msgCompose.SendMsg(msgType, getCurrentIdentity());
 				contentChanged = false;
 				msgCompose.bodyModified = false;
 			}
 			catch (ex) {
-				dump("failed to SendMsg\n");
+				dump("failed to SendMsg: " + ex + "\n");
 			  windowLocked = false;
 			  CommandUpdate_MsgCompose();
sr=sspitzer, check that in.
Checked in. I hoppe that fix the crash. Please test it again tomorrow and if you still freeze, reopen it.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 25

17 years ago
JFD,
Esther installed two builds from this morning(2001-03-23-04) and the recent 
build(2001-03-23-10)on her mac machine. Sending mail did not freeze on both the 
builds. She has mac-os-8.6
I have the same two builds on my mac machine which is 9.0.4 and with same builds 
trying to send freezes the application.
So this should have to do with just on running different version of OS on Mac.  
This problem is due to the SSL setting for SMTP which is set to something else 
that never.
Reopen this bug as you can still reproduce it if your SMTP-SSL pref is not set 
to "never".
Severity: blocker → major
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Reassign to jgmyers
Assignee: ducarroz → jgmyers
Status: REOPENED → NEW
it's possible that is a dup of bug 71680
in fact, it's a bug of 65703!

*** This bug has been marked as a duplicate of 65703 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 31

17 years ago
verified as dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.