Closed Bug 730484 Opened 10 years ago Closed 10 years ago

[New Tab Page] don't iterate NodeList properties when creating cells

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 13
Tracking Status
firefox12 --- fixed

People

(Reporter: ttaubert, Assigned: ttaubert)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file, 1 obsolete file)

Attached patch patch v1 (obsolete) — Splinter Review
From bug 691707 comment #9:

"The problem seems to be |let cells = [new Cell(this, child) for each (child in children)];| in newTab.js, with children a NodeList."

"If I'm not mistaken that will create Cell objects for properties on the NodeList prototype, which doesn't seem what this code wants to do."
Attachment #600557 - Flags: review?(dietrich)
Attachment #600557 - Flags: review?(dietrich) → review+
Attachment #600557 - Attachment is obsolete: true
https://hg.mozilla.org/integration/mozilla-inbound/rev/c928dc7c9dff
Flags: in-testsuite+
Target Milestone: --- → Firefox 13
https://hg.mozilla.org/mozilla-central/rev/c928dc7c9dff
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Comment on attachment 600561 [details] [diff] [review]
patch for checkin

[Approval Request Comment]
Regression caused by (bug #): bug 455553
User impact if declined: see bug 691707
Testing completed (on m-c, etc.): landed a couple of days ago
Risk to taking this patch (and alternatives if risky): low risk
String changes made by this patch: none

This patch is needed for landing bug 691707, which was already approved for aurora. It's a very safe patch, low risk.
Attachment #600561 - Flags: approval-mozilla-aurora?
Comment on attachment 600561 [details] [diff] [review]
patch for checkin

[Triage Comment]
Low risk fix in support of also fixing bug 691707. Approved for Aurora 12.
Attachment #600561 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.