The default bug view has changed. See this FAQ.

Import/Export feed buttons never enabled after bug 716706

VERIFIED FIXED in Thunderbird 13.0

Status

MailNews Core
Feed Reader
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: aceman, Assigned: alta88)

Tracking

({regression})

Trunk
Thunderbird 13.0
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

699 bytes, patch
Bienvenu
: review+
Details | Diff | Splinter Review
(Reporter)

Description

5 years ago
The buttons are inoperational and disabled. It seems you wanted to allow them only on the .isServer item in the list (the account name), but that one does return item=undefined. Please check it.

Also the status line could be shown more prominently, or even highlighted when its content (a message) changes. It took me a while to notice where did my alert dialogs go. I thought they are not working.
(Assignee)

Comment 1

5 years ago
please don't mix multiple unrelated issues in the same bug.

1. the import/export buttons are intentionally meant to be enabled only upon selection of a root account folder, to make clear to the user the imported tree is a child of that folder (and not a selected subfolder) and that the entire account opml is exported (and not a subfolder subset).

2. i'm not clear on the issue. an action (via button) shows the info message directly above the button so i don't know how it can be missed. anyway, unrelated.

closing; if there is an actual error, please reopen with detailed steps to reproduce.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

5 years ago
I have clicked everywhere in the tree of folders and the buttons were never enabled. Please attach a screenshot where I should click to enable Import and Export buttons.
(Assignee)

Comment 3

5 years ago
aha.  the problem is a bad check; if you select the very first tree item, it will be the 0 index and incorrectly fail..  if you add a second feed account and select it, the check will pass.

a fix will be forthcoming.  thanks for the catch.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 4

5 years ago
Created attachment 600718 [details] [diff] [review]
fix.
Attachment #600718 - Flags: review?(dbienvenu)
(Reporter)

Comment 5

5 years ago
Thanks, the fix works for me.

Updated

5 years ago
Attachment #600718 - Flags: review?(dbienvenu) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
http://hg.mozilla.org/comm-central/rev/892d4207a0dd

To make life easier for those checking in patches for you, please follow the directions below to make future patches easier to work with. Thanks!
https://developer.mozilla.org/en/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F
Keywords: checkin-needed
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 13.0

Updated

5 years ago
Keywords: regression
OS: Linux → All
Hardware: x86 → All
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.