Packages and path does not display from confirm dialog

VERIFIED FIXED in mozilla0.9

Status

Core Graveyard
Installer: XPInstall Engine
P1
normal
VERIFIED FIXED
17 years ago
2 years ago

People

(Reporter: Jimmy Lee, Assigned: Blake Ross)

Tracking

({regression})

Trunk
mozilla0.9
x86
Windows NT
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build: 2001-03-22-09-Mtrunk(WIN)

1. From http://jimbob/trigger3.html, click Trigger case button for Acceptance

RESULT:
The confirm dialog does not display the package and path.  Clicking OK button 
does successfully install.

EXPECTED RESULT:
Display package and path from confirm dialog.
(Reporter)

Comment 1

17 years ago
Nominating for Beta.  We have to see what we are about to install.
Keywords: nsbeta1
Argh! More Mozilla Mad Cow Disease from the XUL change landing.
Keywords: nsbeta1 → nsbeta1+, regression

Comment 3

17 years ago
blake, could you lend a hand? thanks
Assignee: dbragg → blakeross
(Assignee)

Comment 4

17 years ago
Created attachment 28695 [details] [diff] [review]
[patch] should fix it

Updated

17 years ago
Priority: -- → P1
Target Milestone: --- → mozilla0.9

Comment 5

17 years ago
*** Bug 73806 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
seeing this on Mac 2001032908 build

Comment 7

17 years ago
has this fix been checked in?
(Assignee)

Comment 8

17 years ago
Not yet.  Dan or Don, can you review this?
Status: NEW → ASSIGNED
r=dveditz for this patch. nsInstallProgressDialog.cpp is still using "value". 
shouldn't that be part of this fix?
(Assignee)

Comment 10

17 years ago
Textbox and progressmeter still use value (well, the text of the progressmeter 
uses label)...knowing that, is there anything in nsInstallProgressDialog.cpp 
that needs changing? I couldn't find anything.
Summary: Packages and path doe not display from confirm dialog → Packages and path does not display from confirm dialog
Ah, I thought everything bug the progressmeter had changed. So no, I guess 
there's no change to nsInstallProgressDialog.cpp
(Reporter)

Comment 12

17 years ago
2001-04-11-09-trunk(WIN)

I am not seeing this problem anymore.
(Assignee)

Comment 13

17 years ago
Yeah, checked in the fix for this.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

17 years ago
Good enough.  Marking Verified!
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.