A Space Shooter runs very slowly, but only on Windows

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: luke, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

7 years ago
(Already discussed this informally, filing a real bug now that the game is public.)  A Space Shooter (http://chrome.aspaceshooter.com) runs well on Linux and OS X but its framerate drags to a halt on Windows.  The game uses WebGL.  This has been tried on different graphics cards (that otherwise run WebGL code fine).  Here is the about:support for one machine:

  Graphics

        Adapter Description
        NVIDIA GeForce GTS 240

        Vendor ID
        0x10de

        Device ID
        0x0607

        Adapter RAM
        1024

        Adapter Drivers
        nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um

        Driver Version
        8.17.12.7533

        Driver Date
        5-20-2011

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.1.7601.17514)

        ClearType Parameters
        ClearType parameters not found

        WebGL Renderer
        Google Inc. -- ANGLE (NVIDIA GeForce GTS 240) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)

        GPU Accelerated Windows
        1/1 Direct3D 10

        AzureBackend
        direct2d
Reporter

Comment 1

7 years ago
I should point out that there is a second Mandreel-compiled game that has this performance fault on Win7, so perhaps there is a particular pattern or feature in the code that is disabling optimization.  The other game is instrumented to show how much time is spent in the JS render loop and it shows very little time which is why I am initially assuming this is a gfx issue.
This was very likely a hit from our bunch of earlier extreme windows webgl regressions.

I can't reproduce on release, and local build is not playing nice with flash, so I can't try to repro there.

Worksforme, but can anyone else repro?
Reporter

Comment 3

7 years ago
WFM also, on the same machine I used to file the bug.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.