Personas cause abnormal behaviour

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: Christo, Unassigned)

Tracking

10 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 600796 [details]
TaskManager.bmp

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Build ID: 20120208060813

Steps to reproduce:

Disk crashed due to age.  Installed FF10.0.1 off usb stick on new disc. Upgraded automatically to 10.0.2. Installed Flashgot for Free Download Manager and a few others.  All fine.  Installed Personas Plus and started looking for Above the Clouds v.3 by Sinine.  As I paged, I did Wear It for some 10 personas.  As it went along the toolbars began going black or green or yellow with base colours, no image.  OK, so restart to work around. Duh.  FF does not come onto the desktop?!  Click shortcut on toolbar - no result.  OK, open Windows Task Manager.  Yes, FF runs.  ???  End process there. Restart PC. Hey! Up flashes FF to die with Windows.  This happened 4 times in total. OK, Uninstall FF.  Delete all custom stuff.  Strip entries in Regedit. Shut down.  Wait a few minutes to get system memory dead.


Actual results:

Restart.  Re-install FF.  FG, FDM again. Fine.  Personas again, This time no Wear Its to get to page 28 Where the Clouds are.  Page 27 download hangs at about 90% down.  Same thing.  OK, so WTM again. Yes, FF show on the Manager.  So, let's see what repeated clicking does. The .bmp file shows firefox at the top with some 146M RAM use.  This built up with only flashes of some 2-3% activity which then stopped.


Expected results:

With FF10.0.1 all worked perfectly.  I got to the Above the Clouds v.3 by random spotting, how exactly I do not remember.  From what I know it seems to be some counting error in paging or sloppy hand-over between personas.  Actions are not completely and securely finalized.  Like falling out of a loop in between FOR . . . NEXT without killing random left-overs in parameters.  Yes, I know that to be ancient, but the new software is even more prone to that kind of error by way of macros disguising the small stuff.  Windows updates automatically. SP's, dotNET's and Java installed.
(Reporter)

Comment 1

6 years ago
Did full uninstall, strip Regedit twice.  Only way to get FF working again. When initially loaded, FF showed 55-59M RAM use in the Task Manager.  I then left clicked the icon top left in the desktop shot to see what TM would do.  I left it at 146M but suspect it would climb further with more clicking.  The system as you see it here has been stable for over five years.  Off the bat, this PC was always protected on the net.  All the software you see here has my One Wire Pliers Award. Pick it up. Use it. Put it down.
Hi Christo, seems like this bug report got overlooked for quite some time. Thanks for your report and all the detail. Is this still an issue for you? I have the feeling this bug is probably obsolete though, so I'd like to close it. Thanks.
Flags: needinfo?(krakkeroe)
(Reporter)

Comment 3

5 years ago
Hi Liz,
Thanks for coming back after a year and a half.  At least you did.  The Personas thing was worked around and forgotten against an experience worse than that.

Since FF 13, Adobe Flash, Air and others make FF crash with a bang.  I updated FF and went back to Adobe 10.3.  But FF kept on insisting upon the use of Adobe.  Adobe kept on updating itself - crash.  There are many other excellent  apps for presenting Youtube et al, like VLC, my favourite Media Player Classic and others I now forget.  You keep insisting on Adobe.  So much for OpenSource software.  Are you (Mozilla collectively) crazy?

It was so bad that I stripped FF and used Avant Browser for some time.  Oh yes, and I did write about this and got no answer.  Just plain, glib dead silence.  Some three  months back that started playing up and I am now reluctantly back to FF.  One incidental Persona and I won't touch it again.  Extensions and add-ons are kept to a minimum.  Flashgot and FDM plus other self-installs which apparently does not cause any weird habits.  What I could not ascertain was whether it was Adobe that caused the Personas misery.

I don't see Youtube videos anymore and I cannot browse HowTo and Fixit properly for detailed problem solutions in handyman situations.  Youtube forces updates for plug-ins and then it WILL BE Adobe 11+!!!

No PICNIC.  I am literate and can program in Cobol, Fortran 4, Several Extended/ Basics. RPG II and Assembler.  I have certificates in electronics hardware. I am not mainly employed in computers, so I need it to work like a tool.  FF does not.

PC. First FF problems on An Acer 5349 laptop. Win 7, More than minimum systems requirements.  Now Win 8 on Lenovo 20150/G580. Ditto.

For other PDF apps, please look at Foxit and Sumatra.

FF is now just another piece of software.

Microsoft's copyrighting is an injunction against freedom of speech and free will.  No, I don't foam around the mouth.  Just look closely.  Then again, that is the joke in the latest on the circuit; Now You See Me with Michael Caine, Woody Harrelson, Morgan Freeman et al.

Exactly what is so difficult in giving me the freedom to choose my plug-in?
Flags: needinfo?(krakkeroe)
Christo,
So it sounds like you've had two different issues, the first an issue with a Persona (now called lightweight themes) which you've resolved if I read correctly? And now it sounds like the second issue you are having is that Flash isn't working properly with Firefox, correct?

Unfortunately Flash has been having a whole set of problems in Firefox for sometime, and while Adobe has slowly been improving their software (BTW, have you tried the most recent version of Flash, 11.8?) things still are a bit tricky. If you'd like to visit our support site, support.mozilla.org we'd love to help you with the Flash issue..

Since this doesn't sound like a bug in Firefox anymore I'm going to close this bug as INVALID, it doesn't mean your issue is INVALID, but just that this is more of a support issue with a third-party program and thus isn't a valid Firefox bug that can be fixed by us in the code. Feel free to follow up at Support!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.