Google Earth plugin freezes when panning camera fast or opening photo. [temporary fix: set dom.ipc.plugins.enabled to false]

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: dusty-2011, Unassigned)

Tracking

10 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

I have Firefox 10.0.2 installed. I go to http://maps.google.nl/ . I switch to the Earth view, essentially opening the Google Earth plugin version 6.1.0.5001 which is installed.


Actual results:

I pan the camera quite fast and the Google Earth plugin freezes. Switching to Full Screen View (through the Firefox menu in the upper left corner) unfreezes the Google Earth plugin. The Google Earth plugin also freezes upon attempting to open a photo, a Wikipedia-link or a youtube-video. Repeatedly going into Fullscreen mode and leaving Fullscreen mode unfreezes Google Earth and the photo or youtube video will appear.


Expected results:

The Google Earth plugin should be stable and shouldn't freeze. I have found a temporary fix for this problem: type about:config in the address bar and type dom.ipc.plugins.enabled in the filter box. Setting dom.ipc.plugins.enabled to false fixes all my issues with Google Earth. I can use Google Earth for hours, panning the camera and viewing photos, youtube-videos etc. and it never freezes.

A related bug report: https://bugzilla.mozilla.org/show_bug.cgi?id=626975
The above bug report has apparently been resolved in firefox 8, but in firefox 10.0.2 I have a similar problem, as I've explained above.
(Reporter)

Comment 1

6 years ago
I forgot to mention two more things. In the default situation, with dom.ipc.plugins.enabled set to true:

When panning the camera in the Google Earth plugin, sometimes the world globe appears for a second, upon which the camera returns to my location by zooming in. I would call this a 'soft crash' of the Google Earth plugin.
Also, sometimes there is a 'hard crash' of the Google Earth plugin. I get a message in Dutch that an internal error has occurred and are requested to refresh the page.

Again the above issues are currently resolved. Most likely by switching dom.ipc.plugins.enabled to false.
(Reporter)

Comment 2

6 years ago
I have done some additional testing, and can verify my above story. The abovementioned problems with the Google Earth plugin are easily reproducable by setting dom.ipc.plugins.enabled to true, restarting Firefox and opening http://maps.google.nl/ . All the problems are not present when setting dom.ipc.plugins.enabled to false, restarting Firefox and opening http://maps.google.nl/. 
I have also tested this on my dad's brand new HP laptop (also running windows 7 64-bits and firefox 10.0.2), and it's the same story there. The google earth plugin regularly freezes. The problems disappear after setting dom.ipc.plugins.enabled to false and restarting the browser.

I hope that there is a better solution for this problem, because with dom.ipc.plugins.enabled set to false for example video's on vimeo no longer play.
(Reporter)

Comment 3

6 years ago
I think this bug has been fixed with the release of Firefox 12.0. I have ran the milktruck demo (http://earth-api-samples.googlecode.com/svn/trunk/demos/milktruck/index.html) numerous times, and the balloons always appeared fine without freezing or crashing the browser or the GE plugin. I have only experienced some very slight delays ("microfreezes") after a balloon appears, which last for less than a second. These "microfreezes" do not appear in Internet Explorer 8, so there is still some room left for improvement, but Firefox 12 is already a huge improvement over Firefox 11. Firefox 11 would still regularly freeze when a balloon appeared in the milk truck demo.

I have also tried the GE plugin on http://maps.google.com/ . I have selected photo thumbnails, video thumbnails and wikipedia thumbnails to appear. I have opened countless of photos, videos and wikipedia items and I never experienced any freezes. On firefox 11, I had regular freezes when opening a photo, video or wikipedia item. On firefox 12, I have never experienced any freezes. I am very satisfied with the performance and the stability of the GE plugin on firefox 12.

I am using:
Firefox 12.0 (current release build)
Google Earth plugin 6.2.0.5788
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.