email replaced when un-archiving

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: andreea.picu, Unassigned)

Tracking

10 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Build ID: 20120213092145

Steps to reproduce:

-- Accidentally archived a couple of the latest emails in my Inbox (typed A unaware that the Thunderbird window had focus).
-- Un-archived those emails, by going to the archives, selecting them, and moving them back to the Inbox



Actual results:

-- Back to the Inbox, the restored emails now still have the same headers, but the content is (very strangely) that of the oldest email in my Inbox
-- Archive and un-archive the same emails again and the headers change as well (again, to the oldest email in my Inbox)



Expected results:

-- The un-archived emails should have had their original content and headers.

Comment 1

7 years ago
(In reply to andreea.picu from comment #0)
Are you using gmail IMAP?
(Reporter)

Comment 2

7 years ago
No I'm not.
Also, in case it matters: archives are in Local Folders.
Can you repair the folder and see if that helps ?
(Reporter)

Comment 4

7 years ago
I don't understand what you mean by "repair" the folder.
(Reporter)

Comment 5

7 years ago
Sorry, just found the "repair" feature. So, repairing the Inbox restores the email.
Still, this does not seem normal... Why is a "repair" feature needed in the first place?
because the db we use is fragile - see http://kb.mozillazine.org/Compacting_folders for some insights.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.