Last Comment Bug 730846 - Download Youtube Videos addon leaves zombie compartments
: Download Youtube Videos addon leaves zombie compartments
Status: RESOLVED FIXED
[MemShrink:P3]
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
https://addons.mozilla.org/en-US/fire...
Depends on:
Blocks: LeakyAddons ZombieCompartments
  Show dependency treegraph
 
Reported: 2012-02-27 09:16 PST by Andrew Williamson [:eviljeff]
Modified: 2013-03-12 18:05 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Andrew Williamson [:eviljeff] 2012-02-27 09:16:58 PST
https://addons.mozilla.org/en-US/firefox/addon/download-youtube-videos/

The above addon leaks zombie compartments in version 12.8 (and possibly earlier versions)

steps to reproduce:
1) navigate to a video page youtube.com
2) press save video button in toolbar to start download
3) cancel download (optional?)
4) check about:memory and see compartment for youtube still there.
Comment 1 Nicholas Nethercote [:njn] 2012-02-28 14:36:20 PST
Andrew, did you contact the author?
Comment 2 Andrew Williamson [:eviljeff] 2012-02-29 07:38:09 PST
The developer was contacted during the review and I included the bug url in it.
Comment 3 Andrew Williamson [:eviljeff] 2012-03-14 09:36:15 PDT
current version (12.9.4) still has the issue.

Steps to reproduce revised to:
1) navigate to a video page youtube.com
2) close tab
3) check about:memory and see compartment for youtube still there.
Comment 4 Andrew Williamson [:eviljeff] 2012-03-21 06:52:08 PDT
version 12.9.6 seems to fix the issue so closing.
Comment 5 silkphoenix 2013-03-11 07:39:23 PDT
(In reply to Andrew Williamson [:eviljeff] from comment #4)
> version 12.9.6 seems to fix the issue so closing.

I am using Version 12.9.6 and still have the same issue. I didn't response until now because I thought it was another YouTube Download add-on that was causing the problem and then I found this bug report.

So could you please reopen this report and notify the developer?

Thank you.
Comment 6 Kris Maglione [:kmag] 2013-03-11 11:15:22 PDT
The add-on is no longer on AMO. Where did you get it?

In any case, these add-ons bordered on malware even on AMO. Off AMO, zombie compartments are probably the least of their problems.
Comment 7 silkphoenix 2013-03-11 11:24:39 PDT
(In reply to Kris Maglione [:kmag] from comment #6)
> The add-on is no longer on AMO. Where did you get it?
> 
> In any case, these add-ons bordered on malware even on AMO. Off AMO, zombie
> compartments are probably the least of their problems.

Thank you, Kris, for your response. I have this add-on for years now and have been in my add-on list ever since. I went to the url that was posted above, and it said "This add-on has been disabled by an administrator.". Then how come Mozilla didn't disable that add-on in my add-on list (like you did with Java)?

Anyway, I have disabled it and everything is back to normal, no more zombies left on my desktop whenever I start and/or restart FF. I'll completely remove it now.

Thank you again.
Comment 8 Kris Maglione [:kmag] 2013-03-12 18:05:40 PDT
We don't blocklist add-ons for these kinds of issues unless they're seriously affecting large numbers of users.

Note You need to log in before you can comment on or make changes to this bug.