Closed Bug 730884 Opened 10 years ago Closed 10 years ago

Firefox Crash [@ msvcrt.dll@0x9cc6 ]

Categories

(Core :: Graphics, defect)

11 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 711656

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash)

Crash Data

Seen while looking at B4 data but this crash spans many other versions. https://crash-stats.mozilla.com/report/list?signature=msvcrt.dll@0x9cc6.

Comments include: switchable graphic... from dedicated to integrated... Problem isn't fixed since ages

https://crash-stats.mozilla.com/report/index/c5b3a087-4641-4088-a2e7-6cb462120227

Frame 	Module 	Signature [Expand] 	Source
0 	msvcrt.dll 	msvcrt.dll@0x9cc6 	
1 	d2d1.dll 	TextStageManager::MapTextureTransferSurface 	
2 	d2d1.dll 	TextStageManager::AddStagesForSubrect 	
3 	d2d1.dll 	HwGlyphRunRealizer::IssueRenderingCommands 	
4 	d2d1.dll 	CHwSurfaceRenderTarget::DrawGlyphRunInternal 	
5 	d2d1.dll 	CCommand_DrawGlyphRun::Execute 	
6 	d2d1.dll 	CHwSurfaceRenderTarget::ProcessBatch 	
7 	d2d1.dll 	CBatchSerializer::FlushInternal 	
8 	d2d1.dll 	DrawingContext::FlushBatch 	
9 	d2d1.dll 	DrawingContext::Flush 	
10 	d2d1.dll 	DrawingContext::EndDraw 	
11 	d2d1.dll 	D2DRenderTargetBase<ID2D1DCRenderTarget>::EndDraw 	
12 	xul.dll 	_cairo_d2d_flush 	gfx/cairo/cairo/src/cairo-d2d-surface.cpp:2710
13 	xul.dll 	_moz_cairo_destroy 	gfx/cairo/cairo/src/cairo.c:454
14 	xul.dll 	xul.dll@0x972df 	
15 	xul.dll 	gfxContext::~gfxContext 	gfx/thebes/gfxContext.cpp:78
16 	xul.dll 	xul.dll@0xe6266f 	
17 	xul.dll 	gfxContext::`scalar deleting destructor' 	
18 	xul.dll 	gfxContext::Release 	obj-firefox/dist/include/gfxContext.h:71
19 	xul.dll 	nsRefPtr<gfxContext>::~nsRefPtr<gfxContext> 	
20 	xul.dll 	mozilla::layers::ThebesLayerD3D10::DrawRegion 	gfx/layers/d3d10/ThebesLayerD3D10.cpp:407
21 	xul.dll 	mozilla::layers::ThebesLayerD3D10::Validate 	gfx/layers/d3d10/ThebesLayerD3D10.cpp:281

Some module correlations:

100% (31/31) vs.   4% (1899/47183) igd10umd32.dll
100% (31/31) vs.   5% (2254/47183) atidxx32.dll
100% (31/31) vs.   5% (2257/47183) atiuxpag.dll
100% (31/31) vs.  15% (7233/47183) d3d10.dll
100% (31/31) vs.  15% (7233/47183) d3d10core.dll
100% (31/31) vs.  15% (7276/47183) d2d1.dll
100% (31/31) vs.  17% (8033/47183) d3d10_1core.dll
100% (31/31) vs.  17% (8033/47183) d3d10_1.dll

Addon Correlations:

26% (8/31) vs.   2% (827/47183) {ACAA314B-EEBA-48e4-AD47-84E31C44796C}
10% (3/31) vs.   1% (414/47183) DivXWebPlayer@divx.com (DivX Web Player, https://addons.mozilla.org/addon/12938)
100% (31/31) vs.  92% (43214/47183) {972ce4c6-7e08-4474-a285-3208198ce6fd} (Default, https://addons.mozilla.org/addon/8150)
19% (6/31) vs.  11% (5379/47183) {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} (Adblock Plus, https://addons.mozilla.org/addon/1865)
10% (3/31) vs.   3% (1552/47183) toolbar@ask.com
6% (2/31) vs.   0% (129/47183) {c50ca3c4-5656-43c2-a061-13e717f73fc8} (Fast Video Download, https://addons.mozilla.org/addon/3590)
6% (2/31) vs.   1% (330/47183) {ef4e370e-d9f0-4e00-b93e-a4f274cfdd5a} (FoxTab, https://addons.mozilla.org/addon/8879)
6% (2/31) vs.   1% (638/47183) {c0c9a2c7-2e5c-4447-bc53-97718bc91e1b} (Easy YouTube Video Downloader, https://addons.mozilla.org/addon/10137)
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 711656
You need to log in before you can comment on or make changes to this bug.