If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

An Exception is thrown when attempting to sync

RESOLVED INVALID

Status

Web Apps
AppsInTheCloud
--
blocker
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: onecyrenus, Assigned: ianbicking)

Tracking

({regression})

Details

(Reporter)

Description

6 years ago
Uncaught TypeError: Object #<Object> has no method 'list'
(anonymous function)include.html:7
Einclude.html:7
b.getinclude.html:7
Einclude.html:7
b.keysinclude.html:7
minclude.html:7
SyncService._processUpdatesinclude.html:7
(anonymous function)include.html:7
c.onreadystatechange

Basically looks like we are attempting to access an element that is not exposed.
(Reporter)

Comment 1

6 years ago
The reproduction steps. 

#1) Open chrome
#2) install apps from apps.mozillalabs.com/appdir
#2) myapps.mozillalabs.com
#3) Click sync
#4) Should continue saying syncing
#5) Check the javascript error console.

Updated

6 years ago
Depends on: 730867
(Assignee)

Comment 2

6 years ago
This is a regression with the new mozApps API, I'll look into it further.

Updated

6 years ago
Keywords: regression
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Comment 3

6 years ago
This should fix this error: 
https://github.com/mozilla/openwebapps/commit/06d12d4a7d6a797314b25d356687980149c1cc37
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Duplicate of this bug: 732475

Updated

6 years ago
Severity: normal → blocker
I was successfully able to login to browser ID and see the two apps I installed with the extension, but this did not work in Chrome. In Chrome, I saw the exact same error David reported with the exact same reproduction steps.
Assignee: ianb → nobody
Status: RESOLVED → REOPENED
Component: HTML → AppSync
QA Contact: appsync
Resolution: FIXED → ---

Updated

6 years ago
Assignee: nobody → ianb
Component: AppSync → HTML
QA Contact: appsync
(Assignee)

Comment 6

6 years ago
I probably shouldn't have closed really, I forgot to mention I haven't yet deployed it.
Component: HTML → AppSync
Knowing that the staging environment will not have the old App Sync server deployed, how should we verify this bug? Will we have to verify this bug then on production? Or should we find another avenue to verify this bug on staging (e.g. a different code path)?
(Assignee)

Comment 8

6 years ago
This might become invalid if we remove appsync from the main server, as I think we may do very soon.
The old app sync server is no longer being supported. The issue to be solved is to take down App Sync on staging and production, which will be tracked in separate bugs.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.