[Azure] OS X Accelerated Layers crashes with large Azure drawtarget

RESOLVED FIXED in Firefox 12

Status

()

Core
Canvas: 2D
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: bas, Unassigned)

Tracking

unspecified
mozilla13
All
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox12 fixed)

Details

(Whiteboard: [qa?])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
In bug 729116, I introduced a new crash test which tests the stability of very large canvases. Unexpectedly this actually crashed on OS X with accelerated layers. I'm disabling it there for now, but we should investigate and fix the underlying issue.
Created attachment 601510 [details] [diff] [review]
Bound the size of CG surfaces to match cairo
Attachment #601510 - Flags: review?(bas.schouten)
(Reporter)

Updated

6 years ago
Attachment #601510 - Flags: review?(bas.schouten) → review+
https://hg.mozilla.org/mozilla-central/rev/bc96e7b9700b
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
Comment on attachment 601510 [details] [diff] [review]
Bound the size of CG surfaces to match cairo

[Approval Request Comment]
Regression caused by (bug #): 692879
User impact if declined: Possible crashes when using large canvases
Testing completed (on m-c, etc.): on m-c, including a crashtest
Risk to taking this patch (and alternatives if risky): Low, we already limit canvases to this size in released versions of Firefox.
String changes made by this patch: none
Attachment #601510 - Flags: approval-mozilla-aurora?

Comment 4

6 years ago
Comment on attachment 601510 [details] [diff] [review]
Bound the size of CG surfaces to match cairo

[Triage Comment]
Approved for Aurora 12 given the low risk evaluation and the return to previous state.
Attachment #601510 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Can we use the test case in bug 729116 comment 0 to test this fix? If not, what's the test?
Whiteboard: [qa?]
You need to log in before you can comment on or make changes to this bug.