Live Bookmarks in bookmarks menu no longer update

RESOLVED FIXED in Firefox 13

Status

()

Firefox
Bookmarks & History
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: gcp, Assigned: mak)

Tracking

({regression})

13 Branch
Firefox 13
x86_64
Windows Vista
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
After a recent change (perhaps Bug 613588), Live Bookmarks no longer update. They are filled on the initial visit from the drop-down menu, but subsequent visits never seem to cause an update. 

Right-click + "Reload live bookmark" does cause them to update.

I'm not 100% positive of what the old behavior was, but generally visiting them show reasonably up-to-date RSS feeds, and IIRC, updated the bookmarks after a few seconds. This no longer happens unless the right-click update is used.

This makes Live Bookmarks mostly useless.
Probably related to Bug 613588.

Comment 2

6 years ago
Confirmed 
http://hg.mozilla.org/mozilla-central/rev/d1b2fd680235
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120227 Firefox/13.0a1 ID:20120227031120


Regression window
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/154d6f29dfb9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120224 Firefox/13.0a1 ID:20120224022630
Reproduce:
http://hg.mozilla.org/integration/mozilla-inbound/rev/7925703fbce6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120224 Firefox/13.0a1 ID:20120224044430
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=154d6f29dfb9&tochange=7925703fbce6
(Assignee)

Comment 3

6 years ago
they refresh when they are opened, if needed. so I don't see what makes them useless here, they refresh more often than they did before.
(Assignee)

Comment 4

6 years ago
Exactly, after every hour if you reopen them they will refresh (provided there is new content)
(Reporter)

Comment 5

6 years ago
My impression is that they *do not* refresh when opened. I left the PC on during the night, and in the morning, upon looking at the Live Bookmarks, all RSS feeds looked the same as the day before (its mostly news feeds, i.e. news from yesterday), and didn't update.

Upon rightclick->Reload live bookmark, the feeds looked totally different, which suggests >1hr of updates arrived at once. 

I'll try to do a more precise measurement.
(Assignee)

Comment 6

6 years ago
do you have add-ons replacing Places views?
on opening a livemark container we ask the service to update it, the service checks when was the last update and if it was more than 1 hour ago starts the update ("live bookmark loading" entry appears in the livemark).
well, unless you had the livemark open in a tree and thus didn't cause a close/open of it?
(Reporter)

Comment 7

6 years ago
>do you have add-ons replacing Places views?

Not that I know of.

>well, unless you had the livemark open in a tree and thus didn't cause a 
>close/open of it?

Not sure what you mean here. I have them in the bookmark menu that opens from the bookmarks button.

I did a more careful experiment (taking a screenshot, waiting 2 hrs, opening the live bookmark and waiting a few minutes, then forcing a refresh via right-click), and I confirm what I already stated in the first comments: the live bookmarks *never* update after the first time. They are completely broken.

Comment 8

6 years ago
Umm, I ran both(build 154d6f29dfb9 and 7925703fbce6)with new profile+one live bookmarks at same time.
I checked update for 3.5 hours.
build 154d6f29dfb9 : updated as expected
build 7925703fbce6 : no update.but  gray "Live Bookmark loading..." stays in menupopup.
(Assignee)

Comment 9

6 years ago
(In reply to Alice0775 White from comment #8)
> build 7925703fbce6 : no update.but  gray "Live Bookmark loading..." stays in
> menupopup.

forever? This to me just looks like the webpage not responding. it should change to failed when the timeout ends.

Do you also have the livemark in the main part of the bookmarks menu?
(Assignee)

Updated

6 years ago
Assignee: nobody → mak77
Status: NEW → ASSIGNED

Comment 10

6 years ago
(In reply to Marco Bonardo [:mak] from comment #9)
> (In reply to Alice0775 White from comment #8)
> > build 7925703fbce6 : no update.but  gray "Live Bookmark loading..." stays in
> > menupopup.
> 
> forever? 
Umm, finally it updated. :) 
The update needed five hours in this test.
I think that something is too severe.

> This to me just looks like the webpage not responding. it should
> change to failed when the timeout ends.
> 
> Do you also have the livemark in the main part of the bookmarks menu?

I created a live bookmarks on Bookmarks toolbar.
And I set always show the Bookmarks toolbar.
(Assignee)

Comment 11

6 years ago
(In reply to Alice0775 White from comment #10)
> (In reply to Marco Bonardo [:mak] from comment #9)
> > (In reply to Alice0775 White from comment #8)
> > > build 7925703fbce6 : no update.but  gray "Live Bookmark loading..." stays in
> > > menupopup.
> > 
> > forever? 
> Umm, finally it updated. :) 
> The update needed five hours in this test.
> I think that something is too severe.

we just get notification from the channel, though I suppose we may set a shorter timeout, will check.
(Assignee)

Updated

6 years ago
Blocks: 613588
Keywords: regression
(Assignee)

Updated

6 years ago
Summary: Live Bookmarks no longer update → Live Bookmarks in bookmarks menu no longer update
(Assignee)

Comment 12

6 years ago
Created attachment 601466 [details] [diff] [review]
patch v1.0

I did this for popups from the toolbar, but forgot to do the same for popups from the menu.
Attachment #601466 - Flags: review?(dietrich)
(Assignee)

Comment 13

6 years ago
(In reply to Alice0775 White from comment #10)
> Umm, finally it updated. :) 
> The update needed five hours in this test.
> I think that something is too severe.

I checked for the timeout, unfortunately bug 407190 means there is no way to set a custom timeout on a nsIHTTPChannel, so far.
(Assignee)

Comment 14

6 years ago
Thank you Mano.
https://hg.mozilla.org/integration/mozilla-inbound/rev/5ac8dc5b03f4
Target Milestone: --- → Firefox 13
https://hg.mozilla.org/mozilla-central/rev/5ac8dc5b03f4
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.