Closed Bug 731188 Opened 10 years ago Closed 8 years ago

Screenshots are not handled correctly in Submit App Details page

Categories

(addons.mozilla.org Graveyard :: Developer Pages, defect, P4)

x86_64
Windows 7
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: cboldan.mozbugs, Assigned: spasovski)

Details

Attachments

(1 file)

Steps to reproduce:
1. Login to APPS Marketplace https://marketplace-dev.allizom.org/en-US/developers
2. Click on "SUBMIT AN APP" link from the header.
3. Get to step 3 (Details) in app submission process.
4. Click the "Add a screenshot" button and select an image.
5. Click the "Add a screenshot" button again and select a text file.
6. Remove the added image.
7. Click the "Continue" button.

Expected results:
There is only an error displayed in the app screenshot section "You must upload at least one screen shot."

Actual results:
The image added at step 4 is displayed again as an added screenshot and there is another screenshot line with no error on it.

Notes/Issues:
Screencast for this issue http://screencast.com/t/deQtpnxiS
Assignee: nobody → cvan
Priority: -- → P1
Target Milestone: --- → 6.4.4
Priority: P1 → --
Priority: -- → P4
If you want this, take it. If not, pass the buck!
Assignee: cvan → dspasovski
I can take this if we bump the milestone to 6.4.5 otherwise please reassign.
Target Milestone: 6.4.4 → 6.4.5
This one is involved...I'll need to let it stir in my mind a little bit. Did quite a bit of analysis on it already and I have an idea of what needs to be done.
Target Milestone: 6.4.5 → 6.4.6
Target Milestone: 6.4.6 → 6.4.7
Target Milestone: 6.4.7 → 6.4.8
Target Milestone: 6.4.8 → ---
Is this still reproducible?
Yes, the bug is still reproducible , but the image added at step 4 is now a blank image. 
Please see the attached screenshot.
Attached image Screenshot
Blocks: 752013
No longer blocks: 710074
No longer blocks: 752013
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.