Closed Bug 731234 Opened 8 years ago Closed 8 years ago

Page source syntax highlighting is wrong on </script> tags

Categories

(Toolkit :: View Source, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla14
Tracking Status
firefox10 --- unaffected
firefox11 --- wontfix
firefox12 --- wontfix
firefox13 --- verified
firefox14 --- verified
firefox-esr10 --- unaffected

People

(Reporter: mjh563, Assigned: hsivonen)

References

()

Details

(Keywords: regression, Whiteboard: [qa+])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120215222917

Steps to reproduce:

1. Load a page that contains some Javascript
2. Press Ctrl+U to view the page source
3. Look at any of the closing </script> tags


Actual results:

The entire tag including the angle brackets is shown in a purple colour.


Expected results:

Only the element name ('script') should be coloured. The brackets and forward-slash should be black, as they are with all other tags.
WFM:
Mozilla/5.0 (X11; Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

Reproduced:
Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (X11; Linux x86_64; rv:12.0a2) Gecko/20120228 Firefox/12.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120228 Firefox/13.0a1
Keywords: regression
Hardware: x86 → All
Version: 11 Branch → Trunk
Last good nightly: 2011-11-01
First bad nightly: 2011-11-02

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=67d1049b0bf9&tochange=978002c0b0ad
Blocks: 482921
Status: UNCONFIRMED → NEW
Component: Untriaged → View Source
Ever confirmed: true
Product: Firefox → Toolkit
QA Contact: untriaged → view.source
Confirmed also on Windows 7.
OS: Linux → All
Duplicate of this bug: 739203
The fix is happening over at bug 742414 because the branch tracking needs to be handled on the grounds of the crash rather than the mishighlight.
Assignee: nobody → hsivonen
Status: NEW → ASSIGNED
https://hg.mozilla.org/integration/mozilla-inbound/rev/fdc8a3e8c956
Flags: in-testsuite+
Target Milestone: --- → mozilla14
AFAICT, ESR is unaffected. I tried running ESR and inspected the code in the repo. The new View Source highlighter was turned off for Firefox 10 even though it originally landed in the 10 train.
https://hg.mozilla.org/mozilla-central/rev/fdc8a3e8c956
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [qa+]
Verified on Firefox 13 beta using the steps to reproduce from the Description that the page source syntax is properly displayed (only the element name 'script' is colored and the brackets and forward-slash are black)

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.6:
Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0
Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20100101 Firefox/13.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:13.0) Gecko/20100101 Firefox/13.0
Verified using Firefox 14 beta 6 that the page source syntax is properly displayed (the 'script' element is colored and the brackets and forward-slash are black). Verified on Win 7, Ubuntu 12.04 and Mac OS X 10.6:

Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0
Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:14.0) Gecko/20100101 Firefox/14.0
You need to log in before you can comment on or make changes to this bug.