RPM the fxhome-search module

RESOLVED FIXED

Status

Pancake
General
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: st3fan, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
RPM the fxhome-search module
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 1

6 years ago
Hmm when deploying this one I get:

[E 120306 12:20:37 web:996] Uncaught exception GET /search/twitter?q=cow (127.0.0.1)
    HTTPRequest(protocol='http', host='127.0.0.1:4321', method='GET', uri='/search/twitter?q=cow', version='HTTP/1.1', remote_ip='127.0.0.1', body='', headers={'Host': '127.0.0.1:4321', 'Accept': '*/*', 'User-Agent': 'curl/7.19.7 (x86_64-unknown-linux-gnu) libcurl/7.19.7 NSS/3.12.7.0 zlib/1.2.3 libidn/1.18 libssh2/1.2.2'})
    Traceback (most recent call last):
      File "/usr/lib/python2.6/site-packages/tornado/stack_context.py", line 208, in _nested
        yield vars
      File "/usr/lib/python2.6/site-packages/tornado/stack_context.py", line 179, in wrapped
        callback(*args, **kwargs)
      File "/usr/lib/python2.6/site-packages/fxhome/search/main.py", line 107, in on_popular_response
        self._render_response()
      File "/usr/lib/python2.6/site-packages/fxhome/search/main.py", line 131, in _render_response
        html = self.render_string("twitter.html", recent=self.recent, popular=self.popular)
      File "/usr/lib/python2.6/site-packages/tornado/web.py", line 544, in render_string
        t = RequestHandler._templates[template_path].load(template_name)
      File "/usr/lib/python2.6/site-packages/tornado/template.py", line 297, in load
        self.templates[name] = self._create_template(name)
      File "/usr/lib/python2.6/site-packages/tornado/template.py", line 327, in _create_template
        f = open(path, "r")
    IOError: [Errno 2] No such file or directory: '/usr/lib/python2.6/site-packages/fxhome/search/twitter.html'

I do see .py files in /usr/lib/python2.6/site-packages/fxhome/search but no html.

I think that means that the .html files are not packaged.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 2

6 years ago
Changed the MANIFEST.in with https://bitbucket.org/mozillapancake/pancake/changeset/9ca47af1bae1

Waiting for a new build to see if that did the trick.
(Reporter)

Comment 3

6 years ago
Last change did the trick. Templates are now included in the RPM.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

6 years ago
This should use Python 2.7 instead of the built-in Python 2.6. It needs a dependency on our pancake-python27 package.

It also needs to reference python like this:

#!/usr/bin/env python2.7

So that it does not depend on a fixed path and will run from both virtualenvs and alternative OSes that we use for development. (OS X and Ubuntu)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

6 years ago
Duplicate of this bug: 731250
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.