Firefox crashes on github.com in mozilla::gl::GLContext::ResizeOffscreenFBO with abort message "X_GLXRender: GLXBadRenderRequest; 2 requests ago" with indirect classic software Mesa

RESOLVED DUPLICATE of bug 696636

Status

()

--
critical
RESOLVED DUPLICATE of bug 696636
7 years ago
7 years ago

People

(Reporter: noxelia, Unassigned)

Tracking

(Depends on: 1 bug, {crash})

10 Branch
x86_64
Linux
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1 Iceweasel/9.0.1
Build ID: 20111222080735

Steps to reproduce:

Just vist http://github.com (without login)
version 10.0.2 32 bit
Linux x86_64


Actual results:

Firefox crashed
running with gdb

###!!! ABORT: X_GLXRender: GLXBadRenderRequest; 2 requests ago: file /builds/slave/rel-m-rel-lnx-bld/build/toolkit/xre/nsX11ErrorHandler.cpp, line 190
###!!! ABORT: X_GLXRender: GLXBadRenderRequest; 2 requests ago: file /builds/slave/rel-m-rel-lnx-bld/build/toolkit/xre/nsX11ErrorHandler.cpp, line 190

Program received signal SIGSEGV, Segmentation fault.
0xf7fd4e9b in mozalloc_abort(char const*) () from /usr/local/appz/firefox/libmozalloc.so


info stack gives an empty stack 
(gdb) info stack
#0  0xf7fd4e9b in mozalloc_abort(char const*) () from /usr/local/appz/firefox/libmozalloc.so
#1  0x00000000 in ?? ()

(gdb) info thread
  41 Thread 0xdbbfcb70 (LWP 2774)  0xf7fdf425 in ?? ()
  40 Thread 0xdc3fdb70 (LWP 2772)  0xf7fdf425 in ?? ()
  39 Thread 0xdcbfeb70 (LWP 2771)  0xf7fdf425 in ?? ()
  38 Thread 0xdd3ffb70 (LWP 2770)  0xf7fdf425 in ?? ()
  37 Thread 0xdf5ffb70 (LWP 2769)  0xf7fdf425 in ?? ()
  36 Thread 0xeebfdb70 (LWP 2768)  0xf7fdf425 in ?? ()
  34 Thread 0xddfffb70 (LWP 2766)  0xf7fdf425 in ?? ()
  32 Thread 0xe03fbb70 (LWP 2764)  0xf7fdf425 in ?? ()
  31 Thread 0xe0bfcb70 (LWP 2763)  0xf7fdf425 in ?? ()
  30 Thread 0xe13fdb70 (LWP 2762)  0xf7fdf425 in ?? ()
  29 Thread 0xe1bfeb70 (LWP 2761)  0xf7fdf425 in ?? ()
  28 Thread 0xe23ffb70 (LWP 2760)  0xf7fdf425 in ?? ()
  27 Thread 0xefbffb70 (LWP 2759)  0xf7fdf425 in ?? ()
  26 Thread 0xe2fffb70 (LWP 2758)  0xf7fdf425 in ?? ()
  23 Thread 0xf0dffb70 (LWP 2755)  0xf7fdf425 in ?? ()
  22 Thread 0xef3feb70 (LWP 2754)  0xf7fdf425 in ?? ()
  17 Thread 0xf05feb70 (LWP 2748)  0xf7fdf425 in ?? ()
  15 Thread 0xf21fdb70 (LWP 2746)  0xf7fdf425 in ?? ()
  14 Thread 0xf29feb70 (LWP 2745)  0xf7fdf425 in ?? ()
  13 Thread 0xf31ffb70 (LWP 2743)  0xf7fdf425 in ?? ()
  12 Thread 0xf3db8b70 (LWP 2742)  0xf7fdf425 in ?? ()
  11 Thread 0xf45b9b70 (LWP 2741)  0xf7fdf425 in ?? ()
  10 Thread 0xf53cfb70 (LWP 2740)  0xf7fdf425 in ?? ()
* 1 Thread 0xf7d236e0 (LWP 2726)  0xf7fd4e9b in mozalloc_abort(char const*) () from /usr/local/appz/firefox/libmozalloc.so




Expected results:

It should not crash

Comment 1

7 years ago
WFM with new, clean profiles:
Mozilla/5.0 (X11; Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (X11; Linux x86_64; rv:12.0a2) Gecko/20120228 Firefox/12.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120228 Firefox/13.0a1
Mozilla/5.0 (X11; Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2 Iceweasel/10.0.2
Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0 Iceweasel/11.0
Mozilla/5.0 (X11; Linux i686 on x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

Comment 2

7 years ago
Reporter, are you running av vanilla Firefox downloaded directly from Mozilla or did you get your browser from another distributor?

Comment 3

7 years ago
Does the issue still occur if you start Firefox in Safe Mode?
https://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 4

7 years ago
Hello,
I made the report with iceweasel (running on debian), thus the signature. By the way iceweasel 9.0.1 also crashes.

BUT the original crash report is from firefox distributed from mozilla. The signature
User-Agent:Mozilla/5.0 (X11; Linux i686 on x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2


Yes, I can confirm the crash still happens with safe mode enabled.

basos

Comment 5

7 years ago
Please post the related Report ID:s from about:crashes in a Mozilla Firefox!
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report

Comment 6

7 years ago
Firefox 9.0.1 is no longer supported. Please upgrade to Firefox 10.0.2.
Do you have the Nouveau 3D driver?
(Reporter)

Comment 7

7 years ago
CrashID url
https://crash-stats.mozilla.com/report/index/c6cccf5f-2512-45fd-a702-3b29e2120228

Additional notes:
Maybe it is related with video driver and/or configuration differences
from xorg.log

[    75.609] (II) LoadModule: "radeon"
[    75.651] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[    75.832] (II) Module radeon: vendor="X.Org Foundation"
[    75.832] 	compiled for 1.11.2.902, module version = 6.14.3

also for some reason my card does not support DRI (maybe related)

[    78.037] (WW) RADEON(0): Direct rendering disabled
[    78.037] (EE) RADEON(0): Acceleration initialization failed
[    78.037] (II) RADEON(0): Acceleration disabled

Updated

7 years ago
Severity: normal → critical
Status: UNCONFIRMED → NEW
Crash Signature: [@ mozalloc_abort | NS_DebugBreak_P | X11Error] [@ TouchBadMemory]
Component: Untriaged → Graphics
Depends on: 722044
Ever confirmed: true
Keywords: crash
Product: Firefox → Core
QA Contact: untriaged → thebes
Summary: Firefox crashes on github.com → Firefox crashes on github.com in mozilla::gl::GLContext::ResizeOffscreenFBO with abort message "X_GLXRender: GLXBadRenderRequest; 2 requests ago"
I, too, have Mesa 7.11 + radeon (r600g) + Linux x86_64, and I can't reproduce this crash.

I've set a bp in SetDimensions and confirmed that:
 - the canvas dimensions are the default (300x150)
 - the context creation options are the default: {alpha = true, depth = true, stencil = false, premultipliedAlpha = true, antialias = true, preserveDrawingBuffer = false}

So I'm out of hypotheses. Can you please attach the whole contents of about:support.
Notice that bug 732441 would fix that and all other crashes on unused WebGL contexts.
Can you please tell me if this page reproduces the crash:
http://people.mozilla.org/~bjacob/webgl.html

Updated

7 years ago
Depends on: 732441
(Reporter)

Comment 11

7 years ago
Yes, webgl.html crashes just like github.
https://crash-stats.mozilla.com/report/index/bp-5b505394-ca96-416c-b653-af5372120302

About:support ehm, crashes mozilla
Severity: critical → normal
Component: Graphics → Build Config
Product: Core → Firefox
(Reporter)

Updated

7 years ago
Component: Build Config → Graphics
Product: Firefox → Core

Updated

7 years ago
Severity: normal → critical
Thanks. about:support also does create a WebGL context, so that explains it.

I see that you're using the Mesa software rasterizer here, so we now know it's a general Mesa bug, not specific to a particular driver.

Please set webgl.disabled in about:config, and retry about:support.

The next thing that would help a lot is if you could download a debug build of Nightly:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012-03-02-mozilla-central-debug/

Unset webgl.disabled, and try webgl.html in the debug build with the following environment variables set:
MOZ_X_SYNC=1 MOZ_GL_DEBUG_ABORT_ON_ERROR=1 MOZ_GL_DEBUG_VERBOSE=1 MOZ_CRASHREPORTER=1

Comment 13

7 years ago
I added a related crash signature with comments talking about Github.
Crash Signature: [@ mozalloc_abort | NS_DebugBreak_P | X11Error] [@ TouchBadMemory] → [@ mozalloc_abort | NS_DebugBreak_P | X11Error] [@ TouchBadMemory] [@ @0x0 | i915_dri.so@0x5b8a2]
FWIW, I'm not reproducing with LIBGL_ALWAYS_INDIRECT=1 and
OpenGL vendor string: Mesa Project
OpenGL renderer string: Software Rasterizer
OpenGL version string: 1.4 (2.1 Mesa 7.11.2)
even with webgl.force-enabled set.

(Unsurprisingly I see "WebGL: Can't get a usable WebGL context" as I expect indirect rendering doesn't provide enough OpenGL support - version 1.4.)
Summary: Firefox crashes on github.com in mozilla::gl::GLContext::ResizeOffscreenFBO with abort message "X_GLXRender: GLXBadRenderRequest; 2 requests ago" → Firefox crashes on github.com in mozilla::gl::GLContext::ResizeOffscreenFBO with abort message "X_GLXRender: GLXBadRenderRequest; 2 requests ago" with indirect classic software Mesa
(Reporter)

Comment 15

7 years ago
Hello,
after disabling webGL (webgl.disabled - true), here is the about:support

  Application Basics

        Name
        Firefox

        Version
        10.0.2

        User Agent
        Mozilla/5.0 (X11; Linux i686 on x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

        Profile Directory

          Open Containing Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

        Crash Reports

          about:crashes

        Memory Use

          about:memory

  Extensions

        Name

        Version

        Enabled

        ID

        Download Statusbar
        0.9.10
        true
        {D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}

        Firebug
        1.9.1
        true
        firebug@software.joehewitt.com

        Firepicker
        1.4.0
        true
        firepicker@thedarkone

        SenSEO
        2.1.0
        true
        senseo@nicosteiner.de

        Show Location
        0.7.1
        true
        {10228D1E-6D25-4ccc-903E-272D66EEC763}

  Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage_override.buildID
        20120215223356

        browser.startup.homepage_override.mstone
        rv:10.0.2

        extensions.lastAppVersion
        10.0.2

        network.cookie.prefsMigrated
        true

        places.database.lastMaintenance
        1328187968

        places.history.expiration.transient_current_max_pages
        103726

        places.history.expiration.transient_optimal_database_size
        165960580

        privacy.cpd.downloads
        false

        privacy.cpd.formdata
        false

        privacy.cpd.history
        false

        privacy.cpd.sessions
        false

        privacy.sanitize.migrateFx3Prefs
        true

        privacy.sanitize.timeSpan
        4

        security.OCSP.disable_button.managecrl
        false

        security.disable_button.openCertManager
        false

        webgl.disabled
        true

  Graphics

        Adapter Description
        Mesa Project -- Software Rasterizer

        Driver Version
        1.4 (2.1 Mesa 7.11.2)

        WebGL Renderer
        false

        GPU Accelerated Windows
        0/1
Severity: critical → normal

Updated

7 years ago
Severity: normal → critical
(Reporter)

Comment 16

7 years ago
Now I tested with nightly 20120307

after visiting webgl.html firefox did not crash

PAGE CONTENT::

got exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMHTMLCanvasElement.getContext]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: http://people.mozilla.org/~bjacob/webgl.html :: start :: line 15" data: no]

TERMINAL OUTPUT::

JavaScript warning: http://people.mozilla.org/~bjacob/webgl.html, line 15: WebGL: Can't get a usable WebGL context
JavaScript warning: http://people.mozilla.org/~bjacob/webgl.html, line 15: WebGL: Can't get a usable WebGL context
JavaScript error: http://people.mozilla.org/~bjacob/webgl.html, line 21: gl is null
WARNING: OpenGL-accelerated layers are not supported on this system.: file ../../../widget/xpwidgets/nsBaseWidget.cpp, line 836


about:support::



  Application Basics

        Name
        Firefox

        Version
        13.0a1

        User Agent
        Mozilla/5.0 (X11; Linux i686 on x86_64; rv:13.0) Gecko/20120307 Firefox/13.0a1

        Profile Directory

          Open Directory

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

        Crash Reports

          about:crashes

        Memory Use

          about:memory

  Extensions

        Name

        Version

        Enabled

        ID

  Important Modified Preferences

      Name

      Value

        browser.cache.disk.capacity
        1048576

        browser.cache.disk.smart_size.first_run
        false

        browser.places.smartBookmarksVersion
        3

        browser.startup.homepage_override.buildID
        20120307013408

        browser.startup.homepage_override.mstone
        13.0a1

        extensions.lastAppVersion
        13.0a1

        gfx.blacklist.direct2d
        4

        gfx.blacklist.layers.direct3d10
        4

        gfx.blacklist.layers.direct3d10-1
        4

        gfx.blacklist.layers.direct3d9
        4

        gfx.blacklist.layers.opengl
        4

        gfx.blacklist.webgl.angle
        4

        gfx.blacklist.webgl.msaa
        4

        gfx.blacklist.webgl.opengl
        4

        network.cookie.prefsMigrated
        true

        places.history.expiration.transient_current_max_pages
        103726

        privacy.sanitize.migrateFx3Prefs
        true

  Graphics

        Adapter Description
        Mesa Project -- Software Rasterizer

        Vendor ID
        Mesa Project

        Device ID
        Software Rasterizer

        Driver Version
        1.4 (2.1 Mesa 7.11.2)

        WebGL Renderer
        Blocked for your graphics card because of unresolved driver issues.

        GPU Accelerated Windows
        0. Blocked for your graphics card because of unresolved driver issues.

        AzureBackend
        skia

  JavaScript

        Incremental GC
        1

I hope this helps

PS: Wow, version numbering now skips major numbers ?? (From 10 to 13). Why is that?
Severity: critical → normal

Updated

7 years ago
Severity: normal → critical
I don't know why each release increments major numbers, but there will be an 11 and 12 release.  They are currently going through QA on our Aurora and Beta branches.

Thanks for testing nightly.
It sounds like this has been fixed sometime between 10.0.2 and nightly 20120307, so marking WFM.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
basos, you may like to find out why indirect rendering is being used on your system.
This is necessary for remote displays but is not normally the default.
"LIBGL_DIAGNOSTIC=1 LIBGL_DEBUG=1 glxinfo" may provide some info.
(I'm not sure how to use those environment variables.  I don't know whether they are boolean or bitmasks.)
Almost certainly, what fixed this is the patch in bug 696636, which blacklists OpenGL 1.x drivers. Indeed the about:support in comment 15 and comment 16 show OpenGL 1.4.
Resolution: WORKSFORME → FIXED

Updated

7 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 696636

Updated

7 years ago
Crash Signature: [@ mozalloc_abort | NS_DebugBreak_P | X11Error] [@ TouchBadMemory] [@ @0x0 | i915_dri.so@0x5b8a2] → [@ mozalloc_abort | NS_DebugBreak_P | X11Error] [@ TouchBadMemory] [@ TouchBadMemory | mozalloc_abort | NS_DebugBreak_P | X11Error] [@ @0x0 | i915_dri.so@0x5b8a2]
You need to log in before you can comment on or make changes to this bug.