If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

News:view of the message header&body posted to newsgroup display 8-bit chars as garbage

VERIFIED WORKSFORME

Status

MailNews Core
Internationalization
P3
normal
VERIFIED WORKSFORME
19 years ago
9 years ago

People

(Reporter: marina, Assigned: nhottanscp)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Steps to reproduce:
Open New Composition window|fill the Subject and body with 8-bit chars|post the
message to netscape.test|view your mesage
//note: thread pane display is fine;
        message header and body show 8-bit chars as garbage
(Assignee)

Comment 1

19 years ago
First, we need to know how was it posted to the newsgroup (i.e. MIME or not).
Marina, which newsgroup did you put the message?
(Reporter)

Comment 2

19 years ago
as i mentioned in the description it was posted to
netscape.test(news.mozilla.org), you can view it. In 4.6 it displays with no
problem, it was posted with MIME, there are two lines in prefs50.js
user_pref("mail.strictly_mime", true);
user_pref("mail.strictly_mime_headers", true);
(Assignee)

Comment 3

19 years ago
In netscape.test, there are both MIME and non MIME headers as following (if
they were sent with the same configuration then that's a sending bug). Bodies
are both quoted.

Subject: 5/28 buildtest: on a =?iso-8859-1?Q?=E7ommenc=E9?= une
        =?iso-8859-1?Q?n=F3uv=E8lle=20journ=E9e=21?=
Date: Fri, 28 May 1999 13:00:38 -0800

Subject: 5/28 buildtest: on a çommencé une nóuvèlle journée!
Date: Fri, 28 May 1999 13:10:51 -0800

Using my local build (contains a fix for 6890), I can see the first header
correctly, the second header failed (because we haven't support non MIME header
display). I have no problem of viewing bodies.

So, could be a sending problem but I think viewing is fine.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 4

19 years ago
Marking as WORKSFORME. If sending problem exists please file a separate bug.

Updated

19 years ago
QA Contact: momoi → marina

Comment 5

19 years ago
marina, please verify the status of this bug.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

19 years ago
I can view message header & body of the news article Ok on my macine with
6/16/99 build, marking as verified.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.