Wrong URLs in the "Total" row at the bottom of tabular reports when JS is enabled and a user field is used for the vertical axis

RESOLVED FIXED in Bugzilla 4.2

Status

()

Bugzilla
Reporting/Charting
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: jochen.mooser, Assigned: Frédéric Buclin)

Tracking

Bugzilla 4.2
Bug Flags:
approval +
approval4.2 +
blocking4.2.1 +

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

Generate a report with a vertical and a horizontal value. This returns a 2 dimenaional table, with many fields having a count of bugzilla numbers inside. 
( e.g. generate with: vertical: QA contact, horizontal: Target milestone)
The table is generated and the number of bug entries in each case is correct. 
Also the total is correct. 


Actual results:

Now click on any number beside a QA contact ( e.g click on a person who has 3 entries): It returns the correct 3 bugzilla entries. There are 2 more entries for this Target Milestone but for different people.

Now click on the number at the bottom, (which here is 5 entries ) beside the name "Total". 



Expected results:

Now it should display the 5 entries from different QA people under this target milestone.
But it does show Zarro bugs found, so no entries are showed. 

Reason is that the formulated query contains: ...&qa_contact=Total&...
Due to that, it will never find any matching entry. This part should be removed when clicking on the bugs in the total line, then it works again.
(Reporter)

Updated

6 years ago
Summary: Report, total → Report, 2d - table: link on "Total" entries not working any more: no bugs showed
(Reporter)

Comment 1

6 years ago
Just found out: only the links on the bottom aren't working. 
The links on the left side are correctly working.
(Assignee)

Comment 2

6 years ago
This was supposed to be fixed in bug 617676, but it still fails if the vertical axis is a user field. Note that it works fine when using the realname, though. If JS is disabled, URLs are correct too.
Status: UNCONFIRMED → NEW
Depends on: 142394
Ever confirmed: true
Flags: blocking4.2.1+
Summary: Report, 2d - table: link on "Total" entries not working any more: no bugs showed → Wrong URLs in the "Total" row at the bottom of tabular reports when JS is enabled and a user field is used for the vertical axis
Target Milestone: --- → Bugzilla 4.2
(Reporter)

Comment 3

6 years ago
Found another problem: when having Product in X and Assignee in Y, then even the links inside the tables aren't working. But here I couldn't yet see the bug in the query.
(Assignee)

Comment 4

6 years ago
Created attachment 602397 [details] [diff] [review]
patch, v1
Assignee: charting → LpSolit
Status: NEW → ASSIGNED
Attachment #602397 - Flags: review?(gerv)
(Assignee)

Comment 5

6 years ago
Created attachment 602414 [details] [diff] [review]
patch, v1.1

My previous patch was wrong.
Attachment #602397 - Attachment is obsolete: true
Attachment #602414 - Flags: review?(gerv)
Attachment #602397 - Flags: review?(gerv)
(Assignee)

Updated

6 years ago
Attachment #602414 - Flags: review?(timello)
Comment on attachment 602414 [details] [diff] [review]
patch, v1.1

Definitely seems to improve things in the scenario described.

Gerv
Attachment #602414 - Flags: review?(gerv) → review+
(Assignee)

Updated

6 years ago
Attachment #602414 - Flags: review?(timello)
(Assignee)

Updated

6 years ago
Flags: approval4.2+
Flags: approval+
(Assignee)

Comment 7

6 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified template/en/default/reports/report-table.html.tmpl
Committed revision 8147.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.2/
modified template/en/default/reports/report-table.html.tmpl
Committed revision 8045.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Duplicate of this bug: 738238
You need to log in before you can comment on or make changes to this bug.