Firefox does not remember screen position after being shifted to secondary screen

RESOLVED DUPLICATE of bug 264030

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 264030
6 years ago
6 years ago

People

(Reporter: painlessdocjohnson, Unassigned)

Tracking

10 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

I'm running Windows 7, 64Bit and have a dual screen setup. I'm running Firefox 10.0.2. My secondary screen (located on the right hand side) has a larger vertical resolution than my primary, making it ideal for viewing some websites with a lot of text. I'm not sure if that is part of the issue, as I don't have another spare to test with. When I drag the Firefox window across to the secondary screen and then maximise it, it is saving that position. After closing Firefox and opening it again, it will no longer save the window position as anything other than maximised on the second screen. I.E dragging it back to the main screen then quitting and reopening means Firefox opens on the secondary screen. 

Steps to reproduce:

Open Firefox on main screen
Drag to second screen and maximise (I'm not sure if maxmising is necessary, but it is how I use Firefox)
Close Firefox
Open Firefox - it opens on second screen
Drag Firefox window to primary screen and maximise
Close Firefox
Open Firefox - it opens on second screen again



Actual results:

Every time you open Firefox subsequently, it opens on the second screen. 


Expected results:

It should be opening on the primary screen. 

I've been able to reset the screen position in the localstore.rdf file in the user profile, but this is quite painful to do on a regular basis. I do note that after this issue has occurred, this section of the file:

  <RDF:Description RDF:about="chrome://browser/content/browser.xul#main-window"
                   screenX="0"
                   screenY="0"
                   width="1066"
                   height="1696"
                   sizemode="maximized" />

Winds up with large negative numbers for screen position. I've just fixed the issue again so the above are the values U enter to reset the screen position, but I'll post the values that are saved once I reproduce the issue again after saving this bug report.
(Reporter)

Comment 1

6 years ago
I've just reproduced this issue the other way around - I've never seen it occur that way before. now Firefox is locked to my primary screen. Apologies, that means this bug report is likely a duplicate of several others, I thought it was unique to the second monitor. 

Just in case, here is the current section of the localstore.rdf file:

  <RDF:Description RDF:about="chrome://browser/content/browser.xul#main-window"
                   screenX="-8"
                   screenY="-8"
                   width="1936"
                   height="1056"
                   sizemode="maximized" />

I believe that Firefox is not correctly handling negative values of screenX or screenY in this file, although I'm not a developer so take that with a grain of salt. I have noticed that every time I've had to reset that section of the localstore.rdf file that at least one of the screenX or screenY has been negative.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 264030
You need to log in before you can comment on or make changes to this bug.