Last Comment Bug 731537 - Script list contains only one script after location change
: Script list contains only one script after location change
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: Trunk
: All All
: P3 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 02:35 PST by Panos Astithas [:past]
Modified: 2012-05-03 06:10 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Panos Astithas [:past] 2012-02-29 02:35:07 PST
Try visiting this page first with the debugger open:

http://astithas.com/test/bp/index.html

and then visit this one, without closing and reopening the debugger:

http://astithas.com/test/a/

See that when the page changes the script list no longer contains all scripts. Screencasts that demonstrate the problem:

http://www.youtube.com/watch?v=ObTdXmtbCOY
http://youtu.be/8D_7lNZ2sNQ
Comment 1 Victor Porof [:vporof][:vp] 2012-03-02 01:53:04 PST
In debugger.js, onScriptsCleared was fired sometimes after onScripts. I guess the order in which scriptsadded and scriptscleared fire isn't reliable?
Comment 2 Victor Porof [:vporof][:vp] 2012-03-02 02:30:57 PST
Here's a log http://pastebin.mozilla.org/1498549 for:
* build opened with tab on http://astithas.com/test/bp/index.html
* started debugger
* refreshed
* location changed to http://astithas.com/test/a/
Comment 3 Panos Astithas [:past] 2012-03-02 06:55:46 PST
OK, I see the problem now: the newScript notifications arrive before the UI has had a chance to finish responding to the tabNavigated notification. I believe that fixing bug 723563 will indirectly fix this problem as well.
Comment 4 Victor Porof [:vporof][:vp] 2012-03-02 07:58:25 PST
(In reply to Panos Astithas [:past] from comment #3)
> OK, I see the problem now: the newScript notifications arrive before the UI
> has had a chance to finish responding to the tabNavigated notification. I
> believe that fixing bug 723563 will indirectly fix this problem as well.

\o/
Comment 5 Panos Astithas [:past] 2012-05-03 06:10:31 PDT
Can't reproduce this any longer, so bug 723563 must have fixed it.

Note You need to log in before you can comment on or make changes to this bug.