Last Comment Bug 731586 - Email notifications about status changes in blockers are incorrectly formatted
: Email notifications about status changes in blockers are incorrectly formatted
Status: RESOLVED FIXED
: regression
Product: Bugzilla
Classification: Server Software
Component: Email Notifications (show other bugs)
: 4.2
: All All
: -- normal (vote)
: Bugzilla 4.2
Assigned To: Frédéric Buclin
: default-qa
:
Mentors:
: 732426 746514 746595 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 06:51 PST by Christian Ruppert
Modified: 2012-04-18 08:31 PDT (History)
4 users (show)
LpSolit: approval+
LpSolit: approval4.2+
LpSolit: blocking4.2.1+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch, v1 (2.24 KB, patch)
2012-03-02 08:54 PST, Frédéric Buclin
dkl: review+
Details | Diff | Splinter Review

Description Christian Ruppert 2012-02-29 06:51:53 PST
Modify a bug that depends or blocks another bug.
You'll receive a mail with incomplete or almost useless content.

<snip>
Return-path: <bugzilla-daemon@landfill.bugzilla.org>
Envelope-to: idl0r@qasl.de
Delivery-date: Wed, 29 Feb 2012 15:36:35 +0100
Received: from landfill.bugzilla.org ([63.245.210.140])
	by mail.qasl.de with esmtps (TLS1.0:DHE_RSA_AES_256_CBC_SHA1:32)
	(Exim 4.77)
	(envelope-from <bugzilla-daemon@landfill.bugzilla.org>)
	id 1S2kdt-0008WU-Je
	for idl0r@qasl.de; Wed, 29 Feb 2012 15:36:35 +0100
Received: from landfill.bugzilla.org (localhost.localdomain [127.0.0.1])
	by landfill.bugzilla.org (8.13.8/8.13.8) with ESMTP id q1TEZQqj024040
	for <idl0r@qasl.de>; Wed, 29 Feb 2012 06:35:26 -0800
From: bugzilla-daemon@landfill.bugzilla.org
To: idl0r@qasl.de
Subject: [Bug 16166] dependency test #1
Date: Wed, 29 Feb 2012 14:35:25 +0000
X-Bugzilla-Reason: Reporter
X-Bugzilla-Type: changed
X-Bugzilla-Watch-Reason: None
X-Bugzilla-Product: FoodReplicator
X-Bugzilla-Component: SaltSprinkler
X-Bugzilla-Keywords: 
X-Bugzilla-Severity: normal
X-Bugzilla-Who: spooky85@gmail.com
X-Bugzilla-Status: CONFIRMED
X-Bugzilla-Priority: P2
X-Bugzilla-Assigned-To: tara@bluemartini.com
X-Bugzilla-Target-Milestone: ---
X-Bugzilla-Changed-Fields: bug_status resolution
Message-ID: 
 <bug-16166-45379-s6vWJBVXCl@http.landfill.bugzilla.org/bugzilla-4.2-branch/>
In-Reply-To: 
 <bug-16166-45379@http.landfill.bugzilla.org/bugzilla-4.2-branch/>
References: <bug-16166-45379@http.landfill.bugzilla.org/bugzilla-4.2-branch/>
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: 7bit
X-Bugzilla-URL: http://landfill.bugzilla.org/bugzilla-4.2-branch/
Auto-Submitted: auto-generated
MIME-Version: 1.0
X-Spam_score: -1.9
X-Spam_score_int: -18
X-Spam_bar: -

https://landfill.bugzilla.org/bugzilla-4.2-branch/show_bug.cgi?id=16166

             Status|CONFIRMED                   |RESOLVED
         Resolution|---                         |FIXED

-- 
You are receiving this mail because:
You reported the bug.
</snip>

So some parts are missing in the body:
Who did that change?

What about the
           What    |Removed                     |Added
---------------------------------------------------------------------------

etc.

HTML or plain text doesn't matter, only 4.2 has been tested, <4.2 is not affected.
Comment 1 Frédéric Buclin 2012-03-02 08:01:17 PST
*** Bug 732426 has been marked as a duplicate of this bug. ***
Comment 2 Frédéric Buclin 2012-03-02 08:03:04 PST
Confirmed.
Comment 3 Frédéric Buclin 2012-03-02 08:54:24 PST
Created attachment 602377 [details] [diff] [review]
patch, v1
Comment 4 David Lawrence [:dkl] 2012-03-02 14:34:51 PST
Comment on attachment 602377 [details] [diff] [review]
patch, v1

Review of attachment 602377 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. r=dkl
Comment 5 David Lawrence [:dkl] 2012-03-02 14:35:19 PST
Comment on attachment 602377 [details] [diff] [review]
patch, v1

Remember to set the flag this time :)
Comment 6 Frédéric Buclin 2012-03-03 07:02:06 PST
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified template/en/default/email/bugmail.html.tmpl
modified template/en/default/email/bugmail.txt.tmpl
Committed revision 8144.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.2/
modified template/en/default/email/bugmail.html.tmpl
modified template/en/default/email/bugmail.txt.tmpl
Committed revision 8044.
Comment 7 Frédéric Buclin 2012-04-18 03:03:24 PDT
*** Bug 746514 has been marked as a duplicate of this bug. ***
Comment 8 Frédéric Buclin 2012-04-18 08:31:47 PDT
*** Bug 746595 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.