Flipping between pages in drawer duplicates pages in drawer

RESOLVED FIXED

Status

Pancake
General
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: dria, Unassigned)

Tracking

Details

Attachments

(1 attachment)

Created attachment 601622 [details]
weird duped pages in drawer

Steps to reproduce:

1) Do a search
2) Tap on a search result
3) Go back to search results page in drawer
4) Tap on another search result

At this point you should have the search results page and two other pages in the drawer.

5) Tap on the first non-search-result page in the drawer
6) Tap on the second non-search-result page in the drawer

Repeat a few times, just tapping back and forth between pages in the drawer.

Result: A bunch of duplicated pages in the drawer.

Expected: No dupes :)

When you quit and restart the app, the extra duped pages go away so they're not really being created in the stack they're just being drawn too many times in the drawer.

Screenshot attached.

Comment 1

6 years ago
The bug described here has been fixed
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.