/video/3 throws a 500 Internal Server Error (logged out)

VERIFIED FIXED

Status

Websites
Firefox Flicks
--
blocker
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: stephend, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

6 years ago
https://firefoxflicks-dev.allizom.org/en-US/video/3 is bombing out on me (throwing a 500).

Mike, do you have the stacktrace?
(Reporter)

Comment 1

6 years ago
https://firefoxflicks-dev.allizom.org/en-US/video/10 does too :-(
(Reporter)

Comment 2

6 years ago
Traceback (most recent call last):

  File "/data/www/firefoxflicks-dev.allizom.org/firefox-flicks/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/www/firefoxflicks-dev.allizom.org/firefox-flicks/flicks/videos/views.py", line 77, in details
    return render(request, 'videos/details.html', d)

  File "/data/www/firefoxflicks-dev.allizom.org/firefox-flicks/vendor/src/django/django/shortcuts/__init__.py", line 44, in render
    return HttpResponse(loader.render_to_string(*args, **kwargs),

  File "/data/www/firefoxflicks-dev.allizom.org/firefox-flicks/vendor/src/django/django/template/loader.py", line 188, in render_to_string
    return t.render(context_instance)

  File "/data/www/firefoxflicks-dev.allizom.org/firefox-flicks/vendor/src/jingo/jingo/__init__.py", line 166, in render
    return self.template.render(context_dict)

  File "/usr/lib/python2.6/site-packages/jinja2/environment.py", line 891, in render
    return self.environment.handle_exception(exc_info, True)

  File "/data/www/firefoxflicks-dev.allizom.org/firefox-flicks/flicks/videos/templates/videos/details.html", line 2, in top-level template code
    {% from 'shared/macros.html' import video_details %}

  File "/data/www/firefoxflicks-dev.allizom.org/firefox-flicks/flicks/base/templates/base.html", line 84, in top-level template code
    {% block content %}{% endblock %}

  File "/data/www/firefoxflicks-dev.allizom.org/firefox-flicks/flicks/videos/templates/videos/details.html", line 33, in block "content"
    data-upvote-url="{{ url('flicks.videos.upvote', video.shortlink) }}"

  File "/data/www/firefoxflicks-dev.allizom.org/firefox-flicks/vendor/src/funfactory/funfactory/helpers.py", line 31, in url
    return reverse(viewname, args=args, kwargs=kwargs)

  File "/data/www/firefoxflicks-dev.allizom.org/firefox-flicks/vendor/src/funfactory/funfactory/urlresolvers.py", line 28, in reverse
    url = django_reverse(viewname, urlconf, args, kwargs, prefix)

  File "/data/www/firefoxflicks-dev.allizom.org/firefox-flicks/vendor/src/django/django/core/urlresolvers.py", line 391, in reverse
    *args, **kwargs)))

  File "/data/www/firefoxflicks-dev.allizom.org/firefox-flicks/vendor/src/django/django/core/urlresolvers.py", line 337, in reverse
    "arguments '%s' not found." % (lookup_view_s, args, kwargs))

NoReverseMatch: Reverse for 'flicks.videos.upvote' with arguments '(u'',)' and keyword arguments '{}' not found.
Duplicate of this bug: 730471

Comment 4

6 years ago
Commit pushed to develop at https://github.com/mozilla/firefox-flicks

https://github.com/mozilla/firefox-flicks/commit/1089053740280115d3c9d57433bfa52f49b68eb5
Give 404 on details page for incomplete video.

fix bug 731645

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

6 years ago
Verified FIXED; thanks:

[10:51:16.894] GET https://firefoxflicks-dev.allizom.org/en-US/video/3 [HTTP/1.1 404 NOT FOUND 79ms]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.