www.aol.com tells mozilla users to upgrade to IE under Linux!

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
VERIFIED FIXED
17 years ago
3 years ago

People

(Reporter: David Hallowell, Assigned: Blake Ross)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
Evangelism bug - hopefully someone here will know who in AOL to contact about this.
AOL are idiots - you visit www.aol.com using Mozilla or indeed Netscape 6 under
Linux and you get a message telling you to upgrade your browser to IE. But I've
heard that Mozilla users on the Windows platform don't have this problem.

The fact that AOL, owners of Netscape, don't even seem to recognise their own
browser (and of course Mozilla which it is based off) on the platforms that it
supports and the fact that it even recommends IE without mentioning Netscape 6
is another joke. I couldn't use IE even if I wanted to because I'm under Linux. 

I suppose they have to recommend IE because of their contract with MS but they
should also recommend Netscape 6, but the whole point is that this works under
Windows (so I've been told) and not under Linux suggests some crappy browser
detection code.
I was unable to reproduce on windows with netscape 4, 6 mozilla opera or ie.
I looked through the javascript code and couldn't find what you are talking 
about. Maybe some directions and screenshots could be given.
(Reporter)

Comment 2

17 years ago
It's Linux only, it works fine under Windows. Obviously they're not detecting
Linux browsers correctly. It appears that they must be doing their browser
detection server side.

Comment 3

17 years ago
I can't reproduce it (build id: 2001032219) under linux
(Reporter)

Comment 4

17 years ago
It was mentioned on a comment on slashdot and so that's what prompted me to
visit the page.

My ISP does transparently cache port 80 content and there's nothing I can do
about that, but I did reload numerous times and still seen it. Assuming that
there's not a problem with my ISP then it looks like AOL have seen it and fixed
the problem.

I'll try viewing the page again under Linux when I get home and will mark this
fixed if it now works.
(Reporter)

Comment 5

17 years ago
It now appears to work, but the strange thing is I don't even get the page I
seen earlier when using a browser such as Lynx, so it appears that the problem
has been fixed now.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
This bug shouldn't be marked FIXED but WORKSFORME because there's nothing fixed
in mozilla to make this site work!

NHF :)

Comment 7

17 years ago
Yes, it should be worksforme, but it is better off leaving it as-is than 
creating spam by changing the status.

Comment 8

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 9

16 years ago
verified on 20011110/linux
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.