Last Comment Bug 731801 - Yahoo! Toolbar 2.4.6.20120119024823 causes zombie compartments
: Yahoo! Toolbar 2.4.6.20120119024823 causes zombie compartments
Status: RESOLVED FIXED
[MemShrink:P2]
:
Product: Tech Evangelism
Classification: Other
Component: Add-ons (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: TheGreatAddonTest
Blocks: LeakyAddons ZombieCompartments
  Show dependency treegraph
 
Reported: 2012-02-29 14:41 PST by Nicholas Nethercote [:njn]
Modified: 2012-04-16 17:35 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Nicholas Nethercote [:njn] 2012-02-29 14:41:29 PST
I used Firefox 10.0.2 on Windows 7.

My installation steps:

- I went to toolbar.yahoo.com which redirected to au.toolbar.yahoo.com (I am in Australia).

- I installed the "Yahoo!7 Toolbar 2.4" add-on.

- I restarted Firefox.

- about:addons tells me the version is "Yahoo! Toolbar 2.4.6.20120119024823".


Steps to reproduce the zombie compartment: 

- Start Firefox.  Open about:memory?verbose in the tab.

- Click the "Toolbar settings" button (which has a cog icon) on the RHS, and choose "Toolbar help".  This opens a new page.

- Close that page.

- Click the "Minimize memory usage" button at the bottom of about:memory?verbose multiple times.

- A zombie compartment for http://au.data.toolbar.yahoo.com/bh/slideout?.intl=au&.pc=&.rev=20120471043&.ver=2.4.6.20120119024823&modid=settings&yid=default is present.

- The zombie also occurs if you instead select "About Yahoo!7 Toolbar" or "Refresh Toolbar" from the same menu.  (And probably other choices from the same menu.)


Alternative steps to reproduce the zombie compartment:

- Start Firefox.  Open about:memory?verbose in the tab.

- Click the "Channels" button near the RHS, and select the "Turn on Channels" drop-down.  This brings up a cricket-related widget in the toolbar.

- Click on the "Matches" button in the widget.  Once it has finished loading the schedule in the pop-up window, close the window via the "X" in the top right corner.

- Click the "Channels" button again and choose "Turn off channels".

- Click the "Minimize memory usage" button at the bottom of about:memory?verbose multiple times.

- A zombie compartment for http://au.data.toolbar.yahoo.com/bh/slideout?.intl=au&.pc=&.rev=20120471043&.ver=2.4.6.20120119024823&modid=scores is present.  (This zombie is almost identical to the previous one.)


Finally, I saw a very similar zombie compartment (i.e. same domain, but the search options were probably different) after clicking some of the other buttons in the toolbar (Mail, Facebook, Shopping, Dating, etc.), *before* I tried the "Channels" feature and the "Toolbar settings" menu.  But I couldn't find steps to reproduce it.  Anyway, this add-on is clearly prone to this zombie compartment in a variety of ways.

Jorge, do we have a contact for Yahoo?
Comment 1 Nicholas Nethercote [:njn] 2012-02-29 14:57:42 PST
I can reproduce the zombie compartment on a development build of Firefox 13 on Ubuntu Linux 11.10.
Comment 2 Jorge Villalobos [:jorgev] 2012-02-29 15:19:18 PST
I sent a message to the contact address in the add-on listing on AMO. Maybe Kev has other contacts we can use.
Comment 3 Jorge Villalobos [:jorgev] 2012-03-21 13:37:05 PDT
The listing has been downgraded to preliminarily reviewed. Still waiting for Yahoo! to respond.

Nicholas, is this a single compartment leak or several?
Comment 4 Nicholas Nethercote [:njn] 2012-03-21 15:25:30 PDT
> Nicholas, is this a single compartment leak or several?

I only ever saw one zombie compartment, and it was always some variant of http://au.data.toolbar.yahoo.com/bh/slideout.
Comment 5 Danial Horton 2012-04-03 07:07:00 PDT
this is not at all surprising.

Frequent attempts to contact yahoo to have them fix the massive delay the 2005 era toolbar caused during firefox startup was completely ignored.

I say block the addon and lets see them come running for answers when people start complaining.
Comment 6 Danial Horton 2012-04-03 07:09:08 PDT
Though what you might be seeing is the fact the addon acts as some sort of mini web page and loads the button bar from the web each start (the cause of the delay back then)
Comment 7 Kev Needham [:kev] 2012-04-03 08:01:13 PDT
I've been in touch with the toolbar team, and they are aware of this bug and are working to correct the leak. I've asked if they can provide an estimate of when it will be released, and will update the memshrink team.
Comment 8 Nicholas Nethercote [:njn] 2012-04-03 15:55:27 PDT
Thanks, Kev.  If you also can get Yahoo to update their AMO contact details so they are correct, that would be great.
Comment 9 Jorge Villalobos [:jorgev] 2012-04-16 17:35:30 PDT
Version 2.4.8.20120412011105 has been reviewed and approved. It doesn't appear to have the leaks mentioned in this bug.

Note You need to log in before you can comment on or make changes to this bug.