Closed Bug 732070 Opened 8 years ago Closed 8 years ago

Feeds no more updating

Categories

(MailNews Core :: Feed Reader, defect)

x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Paenglab, Unassigned)

References

Details

(Keywords: regression)

Feeds don't no more update. In the error console I see following:

Error: Component returned failure code: 0x80570018 (NS_ERROR_XPC_BAD_IID) [nsIJSCID.getService]
Source file: chrome://messenger-newsblog/content/FeedItem.js
Line: 305

and:

Warning: reference to undefined property this.childrenByTagNameNS(channel, ATOM_IETF_NS, "subtitle")[0]
Source file: chrome://messenger-newsblog/content/feed-parser.js
Line: 395

Last good:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120228 Thunderbird/13.0a1

First bad:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120229 Thunderbird/13.0a1
Keywords: regression
confirmed...
I can confirm that for SeaMonkey Trunk too.
Changing to MailNews because of comment 2
Component: General → Feed Reader
Product: Thunderbird → MailNews Core
QA Contact: general → feed.reader
Version: unspecified → Trunk
due to Bug 650784.
Depends on: 650784
Chances are this is a packaging problem. The fix is in bug 650787. 

The relevant bit is:
--- a/mail/installer/package-manifest.in	
+++ a/mail/installer/package-manifest.in	
@@ -353,16 +353,17 @@ 
 ; layout
 @BINPATH@/components/content_base.xpt
 @BINPATH@/components/content_canvas.xpt
 @BINPATH@/components/content_events.xpt
 @BINPATH@/components/content_html.xpt
 @BINPATH@/components/content_htmldoc.xpt
 @BINPATH@/components/content_xslt.xpt
 @BINPATH@/components/content_xtf.xpt
+@BINPATH@/components/html5.xpt
 @BINPATH@/components/htmlparser.xpt
 @BINPATH@/components/layout_base.xpt
 @BINPATH@/components/layout_forms.xpt
 #ifdef NS_PRINTING
 @BINPATH@/components/layout_printing.xpt
 #endif
 @BINPATH@/components/layout_xul.xpt
 @BINPATH@/components/xulapp.xpt
Depends on: 650787
As per bug 650787 comment 18 & 19, I've just landed the change per comment 5.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.