Closed Bug 732117 Opened 8 years ago Closed 8 years ago

Fennec debug intent is broken

Categories

(Firefox Build System :: General, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla13

People

(Reporter: BenWa, Assigned: sriram)

References

Details

Attachments

(1 file)

This is caused by the patches in bug 727960, unapplying them fixes the problem.
Summary: Fennec build intent is broken → Fennec debug intent is broken
I should be more specific:

The native front end starts up but Gecko does not.
(In reply to Benoit Girard (:BenWa) from comment #0)
> This is caused by the patches in bug 727960, unapplying them fixes the
> problem.

Did you try unapplying them one by one?
No, both together, do you have a guess and I'll try it?
1419f0146049 is a likely suspect
Is this actually maple-specific? Presuming not, I'll remove the whiteboard tag.
Whiteboard: maple
With 1419f0146049 unapplied I receive a corrupted stack crash. I do receive some log from Gecko so it is starting up:
E/Gecko   (26551): ### Acquire()
E/Gecko   (26551): Registered Compositor
I/Gecko   (26551): ... requesting window surface from bridge
I/Gecko   (26551): got surface 0x3c6e70
I/Gecko   (26551):  -- creating basic, not accelerated
E/Gecko   (26551): ### Basic layers drawing
E/Gecko   (26551): ### Calling EndDrawing()!
From a quick test, it looks like GeckoThread.run is not even called.
This is actually a regression from bug 728240. Reverting it fixes debug intent for me.
Depends on: 728240
No longer depends on: 727960
I wouldnt recommend reverting the patch. Instead, could you please add a condition there to do debug intent?
Also, onResume() is called whenever Fennec comes to foreground. So, this intent should be processed only once in initialize()
Attached patch PatchSplinter Review
This patch adds the debug intent processing to the startup path.
Attachment #603335 - Flags: review?(mh+mozilla)
Comment on attachment 603335 [details] [diff] [review]
Patch

Review of attachment 603335 [details] [diff] [review]:
-----------------------------------------------------------------

It looks good to me (and, more importantly, works), but I won't pretend I know this code to review it.
Attachment #603335 - Flags: review?(mh+mozilla)
Attachment #603335 - Flags: review?(blassey.bugs)
Attachment #603335 - Flags: feedback+
Attachment #603335 - Flags: review?(blassey.bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/f1a5fd7d0baf

(Please set the assignee when attaching and check when landing, thanks :-))
Assignee: nobody → sriram
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.