MediaWiki navigation shoved horribly down (http://wiki.osgeo.org)

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: jidanni, Unassigned)

Tracking

(Blocks: 1 bug)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 602060 [details]
osgeo.png

User Agent: Mozilla/5.0 (X11; Linux i686; rv:12.0a2) Gecko/20120224 Firefox/12.0a2 Iceweasel/12.0a2
Build ID: 20120224042008

Steps to reproduce:

Browsed http://wiki.osgeo.org/wiki/Main_Page


Actual results:

Noticed the navigation side panel is shoved horribly down, leaving an ugly blank space.


Expected results:

You might say they are using an older Mediawiki, but all other browsers I tested don't display this Firefox bug.
(Reporter)

Comment 1

7 years ago
Never mind what versions etc. they use, http://wiki.osgeo.org/wiki/Special:Version .
One just hopes Firefox would render it like other browsers.
(Reporter)

Comment 2

7 years ago
Yes I used -safe-mode.

Comment 3

7 years ago
Regression window(m-i)
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b727463566a1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110820 Firefox/9.0a1 ID:20110820184005
Fails(blank page):
http://hg.mozilla.org/integration/mozilla-inbound/rev/857f058efa56
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110820 Firefox/9.0a1 ID:20110821013315
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b727463566a1&tochange=857f058efa56
Suspected bug: Bug 679971
Blocks: 679971

Comment 4

7 years ago
jidanni, the version of MediaWiki used by that site is out of date, and incorrectly sniffs for Navigator.taintEnabled() for browser detection. The site needs to update it's MediaWiki install. See bug 683151 comment 8 for the minimum newer version they need to install.
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: Untriaged → English US
Ever confirmed: true
Product: Firefox → Tech Evangelism
QA Contact: untriaged → english-us
Version: 12 Branch → unspecified

Comment 5

7 years ago
And by "it's" I of course meant "its"... doh :-/

Comment 6

7 years ago
Who is going to contact them? jidanni?
OS: Linux → All
Hardware: x86 → All
Summary: MediaWiki navigation shoved horribly down → MediaWiki navigation shoved horribly down (http://wiki.osgeo.org)
(Reporter)

Comment 7

7 years ago
I find it hard to contact individual website owners.
I am glad you found the cause though.
So this legacy of sniffing leaves pain for generations.

Anyway, I usually use emacs-w3m, so don't really usually see anybody's CSS.

B y e....

Comment 8

6 years ago
This is fixed. If not by updating their mediawiki installation, then by our changes in bug 679971.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Does it mean we have given up to remove navigator.taintEnabled()? If so, bug 679971 should be WONTFIX'ed.

Comment 10

6 years ago
> Does it mean we have given up to remove navigator.taintEnabled()?
(Firefox 9 broke a top-10 site in Poland on release day, and some others. I proposed to do it different before release (e.g. bug 679971 comment 15), but ... )

> If so, bug 679971 should be WONTFIX'ed.
Well, bug 679971 is now one of our x-thousand open bugs. May be later?
Has the proposed warning (bug 679971 comment 65) been added? I'm afraid not.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.