Closed Bug 732143 Opened 8 years ago Closed 8 years ago

WebGL on maemo6 N9 does not work anymore after FBO switch 720467

Categories

(Core :: Graphics, defect)

ARM
Maemo
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla13

People

(Reporter: romaxa, Assigned: romaxa)

References

Details

Attachments

(1 file)

Found that nightly m-c fennec fail to initialize WebGL context on N9 after landing bug720467
Change in GetShared context caused breakage.
https://hg.mozilla.org/mozilla-central/rev/7f6db301b290#l1.132
Assignee: nobody → romaxa
Status: NEW → ASSIGNED
Attachment #602072 - Flags: review?(joe)
Attachment #602072 - Flags: review?(joe) → review+
Keywords: checkin-needed
Pushed to inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/68b1f715d7c9
Keywords: checkin-needed
Target Milestone: --- → mozilla13
https://hg.mozilla.org/mozilla-central/rev/68b1f715d7c9
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 602072 [details] [diff] [review]
Don't call recursively GetSharedContext

[Approval Request Comment]
Regression caused by (bug #720467): 
User impact if declined: WebGL feature for N9 FF release
Testing completed m-c
Risk to taking this patch: should be minimal, Linux GTK and maemo builds only
Attachment #602072 - Flags: approval-mozilla-beta?
Attachment #602072 - Flags: approval-mozilla-aurora?
Comment on attachment 602072 [details] [diff] [review]
Don't call recursively GetSharedContext

[Triage Comment]
Firefox 11 is complete at this point, but we can approve for Aurora 12 given the low risk evaluation.
Attachment #602072 - Flags: approval-mozilla-beta?
Attachment #602072 - Flags: approval-mozilla-beta-
Attachment #602072 - Flags: approval-mozilla-aurora?
Attachment #602072 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.