Repeating DELETE key stops repeating when AwesomeBar reverts from Go to Search mode

RESOLVED WORKSFORME

Status

()

P5
normal
RESOLVED WORKSFORME
7 years ago
7 months ago

People

(Reporter: cpeterson, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox14 affected, firefox15 affected, firefox16 affected, firefox17 affected, blocking-fennec1.0 -, fennec-)

Details

(Whiteboard: [vkb])

(Reporter)

Description

7 years ago
STR:
1. In AwesomeBar, enter some URL-like text such as "example.com".
2. Press and hold the DELETE key to erase the text.

AR:
The "e.com" suffix will be deleted, but then the delete will stop when the AwesomeBar switch from Go to Search mode.

ER:
The DELETE key should repeat and let you erase all the text.

I believe the problem is that the InputMethodManager drops buffered key events when we call imm.restartInput() to switching modes.
blocking-fennec1.0: --- → ?
Whiteboard: [vkb]
Assignee: nobody → cpeterson
blocking-fennec1.0: ? → -
I believe this bug has affected code which causes my filed bug 725298 where I dont always see characters visibly drawn in the URL field. It tends to happen when modes are switched from "Search" to "Go".
(Reporter)

Comment 2

7 years ago
Triage, this bug needs a priority.
blocking-fennec1.0: - → ?
blocking-fennec1.0: ? → -
Priority: -- → P5
(Reporter)

Updated

7 years ago
Component: General → IME
Kind of annoying still; tracking?
tracking-fennec: --- → ?
status-firefox14: --- → affected
status-firefox15: --- → affected
status-firefox16: --- → affected
status-firefox17: --- → affected
tracking-fennec: ? → -
(Reporter)

Updated

6 years ago
Assignee: cpeterson → nobody
Works for me on a Pixel 2 XL and Android 8.1.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.