Closed Bug 732176 Opened 8 years ago Closed 7 years ago

quick filter bar filtering on body, but body is unchecked

Categories

(Thunderbird :: Search, defect)

x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: wsmwk, Unassigned)

References

Details

I got into a state where quick filter bar is filtering on body, but body is unchecked. specifically, subject was enabled and body was not.

workaround - check body, then uncheck it.  search correctly changes to not search body

I don't know how I got in this state.

unclear yet if this is caused by IagoSRL's unified search addon 
https://addons.mozilla.org/en-US/thunderbird/addon/unified-search-187593/
Hi Wayne,

When you have this problem, are you using the Unified Search widget bar to check/uncheck the body filter?

If you have the standard Quick Filter Bar hidden, in the extension options there is a checkbox to show it again (uncheck 'disable and hide quick filter bar..'). Can you try to confirm the bug using only the standard Quick Filter Bar? And with the extension disabled?

Something that can be happen is that Unified Search have unchecked the 'body filter', while QFB have it checked (that means a but in Unified Search).

Note: Because Unified Search is only about UI, there is no filtering being doing from the widget, just it does is synchronize their options with the QFB and this last do the filtering work.

Thanks a lot!
(In reply to IagoSRL from comment #1)
> Hi Wayne,
> 
> When you have this problem, are you using the Unified Search widget bar to
> check/uncheck the body filter?

yes. 

> If you have the standard Quick Filter Bar hidden, in the extension options
> there is a checkbox to show it again (uncheck 'disable and hide quick filter
> bar..'). Can you try to confirm the bug using only the standard Quick Filter
> Bar? And with the extension disabled?

will try. but since i've only seen this once and don't have clear STR, I have doubts about being able to reproduce.

> Something that can be happen is that Unified Search have unchecked the 'body
> filter', while QFB have it checked (that means a but in Unified Search).

interesting. however that shouldn't explain my problem. because i did 
"check body, then uncheck it." and it it stopped filtering body. which means before I made the change, the  backend should have thought that I had body unchecked.

> Note: Because Unified Search is only about UI, there is no filtering being
> doing from the widget, just it does is synchronize their options with the
> QFB and this last do the filtering work.
> 
> Thanks a lot!
Blocks: 770020
I haven't seen this since
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.