Closed Bug 732186 Opened 8 years ago Closed 8 years ago

Deleting Live bookmarks causes Errors

Categories

(Toolkit :: Places, defect, minor)

13 Branch
x86
Windows 7
defect
Not set
minor

Tracking

()

RESOLVED FIXED
mozilla13

People

(Reporter: alice0775, Assigned: mak)

References

Details

Attachments

(1 file)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/1c3b291d0830
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120301 Firefox/13.0a1 ID:20120301031135

Deleting Live bookmarks causes Errors.
(no other failure)


Reproducible: Always

1. Start Firefox with new profile and show Bookmarks toolbar
2. Subscribe RSS feed of https://bugzilla.mozilla.org/buglist.cgi?chfieldto=Now;chfield=[Bug%20creation];chfieldfrom=-96h;order=Bug%20Number;bug_status=UNCONFIRMED;bug_status=NEW;bug_status=ASSIGNED;bug_status=REOPENED;bug_status=RESOLVED;bug_status=VERIFIED;product=Core;product=Firefox;product=Mozilla%20Application%20Suite;product=Thunderbird;product=Toolkit;product=Tech%20Evangelism;product=MailNews%20Core;list_id=2503836
3. Popup Live bookmarks on Bookmarks toolbar and Confirm that items are enumerated
4. Delete the Live bookmarks.


Actual Results:
  Errors at step4;

Timestamp: 2012/03/02 3:54:36
Error: this._resultObserversList is undefined
Source File: resource:///components/nsLivemarkService.js
Line: 967

Timestamp: 2012/03/02 3:54:54
Error: this._resultObserversList is undefined
Source File: resource:///components/nsLivemarkService.js
Line: 983

Timestamp: 2012/03/02 3:55:01
Error: this._resultObserversList is undefined
Source File: resource:///components/nsLivemarkService.js
Line: 983


Expected Results:
  no error
likely a minor glitch, I noticed a similar error on shutdown.
Assignee: nobody → mak77
Blocks: livemarksIO
Attached patch patch v1.0Splinter Review
as I thought was a trivial and harmless thing, when a livemark is terminated it is deleted and the next abort tries to set the status, that tries to use the list.
Attachment #602178 - Flags: review?(dietrich)
Comment on attachment 602178 [details] [diff] [review]
patch v1.0

Review of attachment 602178 [details] [diff] [review]:
-----------------------------------------------------------------

sounds ok. r=me with a test.
Attachment #602178 - Flags: review?(dietrich) → review+
(In reply to Dietrich Ayala (:dietrich) from comment #3)
> Comment on attachment 602178 [details] [diff] [review]
> patch v1.0
> 
> Review of attachment 602178 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> sounds ok. r=me with a test.

which kind of test? everything works fine, the only problem was a spurious error thrown to the console.
Sorry, didn't realize it's just console spew. No test required then.
https://hg.mozilla.org/integration/mozilla-inbound/rev/2d9f9bef5aa0
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
https://hg.mozilla.org/mozilla-central/rev/2d9f9bef5aa0
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.