Allow "Don't load tabs until selected" to be checked/unchecked if "Show my home page" is selected

RESOLVED DUPLICATE of bug 720154

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 720154
6 years ago
6 years ago

People

(Reporter: njn, Unassigned)

Tracking

({relnote})

unspecified
relnote
Points:
---

Firefox Tracking Flags

(firefox13-)

Details

(Reporter)

Description

6 years ago
+++ This bug was initially created as a clone of Bug #711193 +++

(I think this is fallout from bug 711193.)

The "When Firefox starts" option has three choices:

- Show my home page
- Show a blank page
- Show my windows and tabs from last time

Beneath that is the "Don't load tabs until selected" checkbox.  It's greyed out unless you choose "Show my windows and tabs from last time".  However, that checkbox has an effect if you have "Show my home page" and the home page is about:home -- if you choose "Restore Previous Session", the checkbox dictates whether the session restore is lazy or eager.

Now, you can workaround this by temporarily selecting "Show my windows and tabs from last time", checking/unchecking the box, and then going back to "Show my home page".  But that's a bit annoying;  you should be able to check/uncheck it in the case I described.

I noticed this because in some of my profiles I have about:home as my start page and I use "Restore Previous Session" a lot, and I noticed that just today the session restore had switched to being lazy.
(In reply to Nicholas Nethercote [:njn] from comment #0)
> +++ This bug was initially created as a clone of Bug #711193 +++
> 
> (I think this is fallout from bug 711193.)

No, that's just the way it always has been (since bug 648683), but it's probably more obvious to you now.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 720154
You need to log in before you can comment on or make changes to this bug.