Closed Bug 732362 Opened 10 years ago Closed 10 years ago

Cannot submit an app with the same domain as a deleted app

Categories

(addons.mozilla.org Graveyard :: Developer Pages, defect, P2)

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: vcarciu, Assigned: cvan)

References

()

Details

(Keywords: regression)

Prerequisites:
Mozilla/5.0 (Windows NT 5.1; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

Steps to reproduce:
1.Go to apps marketplace and login : https://marketplace.mozilla.org/en-US/developers/
2.Click the "Submit an app" button
3.Add a valid manifest and press the "Validate" button (https://marketplace.mozilla.org/en-US/developers/submit/app/manifest)
4.When validation is passed, click the "Continue" button.

Expected results:
The submission process will continue with step 3(Details)

Actual results:
App manifest is required again and user is not able to pass this step.

Please see the screencast for this bug : http://screencast.com/t/F7Ho6jImZle
This works just fine for me with my manifest (http://apps5.dekkostudios.com/seavan.webapp). Can I see what your manifest looks like?
did you try this with a new browser ID account? this might be related to the recent agreement acceptance changes.
(In reply to Kumar McMillan [:kumar] from comment #2)
> did you try this with a new browser ID account? this might be related to the
> recent agreement acceptance changes.

I don't think so. I explicitly accepted the agreement and yet I see this issue. I am going to reduce the severity since it happens only with this app.
Severity: critical → major
Summary: Cannot submit apps on https://marketplace.mozilla.org/en-US/developers/ . → Cannot submit apps on marketplace.mozilla.org using MARBLE RUN
The problematic manifest URL: http://marblerun.at/manifest.webapp
sounds like a hidden form error
Assignee: nobody → kumar.mcmillan
Target Milestone: --- → 6.4.5
Priority: -- → P3
Target Milestone: 6.4.5 → 6.4.6
Target Milestone: 6.4.6 → 6.4.7
Assignee: kumar.mcmillan → cvan
OS: Windows XP → All
Priority: P3 → P2
Hardware: x86 → All
This appears fixed. I wonder if it was related to the Sunbird application issue. Works for me!
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Still reproducible using the original scenario.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
cvan, did you check the code to make sure we are catching all form errors, like non_field_errors? something hidden might be causing is_valid() to return False here.
STR:
1. Make sure that WEBAPPS_UNIQUE_BY_DOMAIN = True
2. Upload an app
3. After successful submission, delete the app
4. Try to upload the same app again(having the same domain as the deleted app).

expected behavior:
User is able to upload the same app again

actual behavior:
App upload fails. in -dev it shows the error- "An app already exists on this domain; only one app per domain is allowed."
Summary: Cannot submit apps on marketplace.mozilla.org using MARBLE RUN → Cannot submit an app with the same domain as a deleted app
https://github.com/mozilla/zamboni/commit/4731bbd
https://github.com/mozilla/zamboni/commit/08a3bae
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
the form error now shows up in the right place after https://github.com/mozilla/zamboni/commit/a436ae4
Verified Krupa's scenario from comment #9 and now everything is working as expected. I was able to submit same app many times after deleting it.

Unfortunately , I was not able to test the original scenario on production because all tried domains were already in use.

Krupa, can you please send me a new app(or delete one from production) to test the original scenario in production?
Verified as fixed in production by submitting a previously deleted app.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.