Debugger should have a key command to popup script selection

RESOLVED DUPLICATE of bug 796135

Status

()

Firefox
Developer Tools: Debugger
P3
normal
RESOLVED DUPLICATE of bug 796135
6 years ago
5 years ago

People

(Reporter: rc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Many editors have the ability to rapidly select a file from a project. We should implement a similar solution for the script debugger. A key command can popup a quick script selection menu (we can reuse the menu from the scripts menulist) and an edit field for typing the name of the file. It should be smart enough that you only need to type a few characters for the correct file to be highlighted.

for reference, see iswitch-buffer in emacs, cmd-T in TextMate, cmd-P in Sublime2, $X in ${YOUR_FAVORITE_EDITOR}.
(Reporter)

Updated

6 years ago
Priority: -- → P3

Comment 1

5 years ago
triage. Filter on PINKISBEAUTIFUL
Component: Developer Tools → Developer Tools: Debugger
Fixed by bug 796135, accel+P is the shortcut, ui is attachment 689664 [details].
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 796135
You need to log in before you can comment on or make changes to this bug.