pngsuite-gamma/* fails on android when we turn browser.tabs.remote=false

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
On android xul, we run with e10s and our reftest harness will setup the xul window to have the remote=true attribute.  For native fennec we have the preference to turn on e10s set, but we don't read it.  This means that reftest is still thinking we are remote, but in reality we are not.  

In trying to turn this off, I found that the 3 tests which pass (15 are already commented out as fails-if(android)) fail.  

The log file showing this is here:
http://people.mozilla.org/~jmaher/android_reftests/pngsuite/pngsuite-gamma.log

Ideally we should figure out what is the root cause for all 15 of the gamma tests and create an appropriate reftest condition for it.
(Reporter)

Comment 1

6 years ago
these appear to be running fine in a more recent build.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.