Closed Bug 732764 Opened 8 years ago Closed 8 years ago

gfx/angle/src/compiler/Types.h:211: error: 'abort' was not declared in this scope

Categories

(Core :: Graphics, defect)

ARM
Maemo
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla13
Tracking Status
firefox-esr10 --- fixed

People

(Reporter: romaxa, Assigned: romaxa)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file, 2 obsolete files)

Attached patch Add stdlib include (obsolete) — Splinter Review
Attempt to compile m-c on scratchbox Maemo N9 endup with this error:

c++ -o Compiler.o -c  -fvisibility=hidden -DANGLE_USE_NSPR -DANGLE_BUILD -DCOMPILER_IMPLEMENTATION -DANGLE_DISABLE_TRACE -DANGLE_COMPILE_OPTIMIZATION_LEVEL=D3DCOMPILE_OPTIMIZATION_LEVEL0 -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES  -DSTATIC_EXPORTABLE_JS_API -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux -Igfx/angle/include -Igfx/angle/src -Igfx/angle -I. -I../../dist/include -I../../dist/include/nsprpub  -Iobj-build/dist/include/nspr -Iobj-build/dist/include/nss      -fPIC -frtti -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -Wno-long-long -fno-exceptions -fno-strict-aliasing -std=gnu++0x -pthread -ffunction-sections -fdata-sections -pipe -DNDEBUG -DTRIMMED -gdwarf-2 -O3 -g -fomit-frame-pointer   -DMOZILLA_CLIENT -include ../../mozilla-config.h -MD -MF .deps/Compiler.pp gfx/angle/src/compiler/Compiler.cpp
In file included from gfx/angle/src/compiler/intermediate.h:20,
                 from gfx/angle/src/compiler/BuiltInFunctionEmulator.h:13,
                 from gfx/angle/src/compiler/Compiler.cpp:7:
gfx/angle/src/compiler/Types.h: In member function 'const TString& TType::getTypeName() const':
gfx/angle/src/compiler/Types.h:211: error: 'abort' was not declared in this scope
make[1]: *** [Compiler.o] Error 1
make[1]: Leaving directory `obj-build/gfx/angle'
make: *** [default] Error 2
Attachment #602695 - Flags: review?(joe)
Attached patch Compile angle fix stdlib include (obsolete) — Splinter Review
Assignee: nobody → romaxa
Attachment #602695 - Attachment is obsolete: true
Attachment #602696 - Flags: review?
Attachment #602695 - Flags: review?(joe)
Comment on attachment 602696 [details] [diff] [review]
Compile angle fix stdlib include

Review of attachment 602696 [details] [diff] [review]:
-----------------------------------------------------------------

Please include cstdlib, and update angle-castrate-bug-241.patch
Attachment #602696 - Flags: review? → review-
Attached patch cstdlib includeSplinter Review
Attachment #602696 - Attachment is obsolete: true
Attachment #602738 - Flags: review?(bjacob)
Comment on attachment 602738 [details] [diff] [review]
cstdlib include

Review of attachment 602738 [details] [diff] [review]:
-----------------------------------------------------------------

Alright, thanks. But anyone landing this must add this to gfx/angle/....patch and gfx/angle/README.mozilla.
Attachment #602738 - Flags: review?(bjacob) → review+
Keywords: checkin-needed
checkin-needed isn't great for something that requires special care to land. doing it.
Keywords: checkin-needed
oh, sorry, i can see that the patch has the patch-file update. thanks, and sorry. landing.
http://hg.mozilla.org/integration/mozilla-inbound/rev/71995d5b92a1
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla13
https://hg.mozilla.org/mozilla-central/rev/71995d5b92a1
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 602738 [details] [diff] [review]
cstdlib include

Regression caused by (bug 699033): 
Testing completed on m-c: 
Risk to taking this patch: build fix, risk minimal
String changes made by this patch: no
Attachment #602738 - Flags: approval-mozilla-aurora?
Comment on attachment 602738 [details] [diff] [review]
cstdlib include

[Triage Comment]
Build fix - approved for Aurora 12.
Attachment #602738 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 602738 [details] [diff] [review]
cstdlib include

[Approval Request Comment]
Regression caused by (bug #699033): 
User impact if declined: failure to build for some downstreams
Risk to taking this patch (and alternatives if risky): Adding a #include, low risk
String changes made by this patch: none
Attachment #602738 - Flags: approval-mozilla-esr10?
Attachment #602738 - Flags: approval-mozilla-beta?
Comment on attachment 602738 [details] [diff] [review]
cstdlib include

Turns out since beta is what was aurora when this landed, beta has it. ESR is still affected, though.
Attachment #602738 - Flags: approval-mozilla-beta?
Duplicate of this bug: 737781
Comment on attachment 602738 [details] [diff] [review]
cstdlib include

[Triage Comment]
Build fix - accepting for ESR as well. See https://wiki.mozilla.org/Release_Management/ESR_Landing_Process for details.
Attachment #602738 - Flags: approval-mozilla-esr10? → approval-mozilla-esr10+
Oleg, can you land this?
I don't think this needs QA verification at this point, marking qa-.
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.