If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mail Database broken if mozilla chrashes or if disconnected while downloading new POP mail

VERIFIED WORKSFORME

Status

MailNews Core
Database
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: luserjeff, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; 0.8) Gecko/20010215
BuildID:    2001021508

I have noticed on several occasions where when Mozilla crashes when the mail
winodw is open (I haven't seen it happen when Moz crashes and the mail window is
closed), or when my Dial-Up connection drops whilst downloading my POP mail,
that the mail database seems broken.  By this I mean that many, if not all, of
the messages in my various folders get moved up to that accounts Inbox, or when
I try to read a Message, and I click on it's subject I get a different e-mail. 
I can only tell it's a different mail because the subject and the body don't
make sense together, though Mozilla shows the header of the mail I'm trying to see.

Reproducible: Sometimes
Steps to Reproduce:
1.Be downloading POP mail and close the Dial-Up
or
2.Crash Mozilla while collecting POP mail or simply crash Mozilla with the mail
reader open

Actual Results:  When I reopened Mozilla (sometimes after a reboot), I had the
symptoms described in the description

Expected Results:  Should have retained the database in it's state before the crash

Comment 1

17 years ago
Reporter your using a build that is over a month old. Try downloading 0.8.1 and
see if that fixes the problem. Report back either way. Thanks in advance.

Comment 2

17 years ago
Marking WORKSFORME no problems here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.