Last Comment Bug 732782 - Zombie compartment in Autopager
: Zombie compartment in Autopager
Status: RESOLVED FIXED
[MemShrink:P3]
:
Product: Firefox
Classification: Client Software
Component: Untriaged (show other bugs)
: 13 Branch
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: ZombieCompartments
  Show dependency treegraph
 
Reported: 2012-03-04 04:18 PST by Jakob
Modified: 2012-09-05 02:30 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jakob 2012-03-04 04:18:52 PST
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120303 Firefox/13.0a1
Build ID: 20120303031033

Steps to reproduce:

1. Install AutoPager (https://addons.mozilla.org/en-US/firefox/addon/autopager/)
2. Go to a site that has AutoPager rules defined, f.e Engadget.com
3. Press Yes when prompted with "Do you want to enable auto paging on this site"
4. Scroll the site to the bottom to start a auto page.
5. Close site




Actual results:

Zombie compartment in about:compartments and about:memory.
Comment 1 Nicholas Nethercote [:njn] 2012-05-09 18:50:15 PDT
Have we contacted the author of AutoPager?
Comment 2 Jakob 2012-05-11 11:21:42 PDT
I sent the author a email on April 10th; no reply. Regarding your comment https://bugzilla.mozilla.org/show_bug.cgi?id=695480#c53 I can reproduce, but it doesn't seem that Autopager is working properly, it's only possible to autopage one page, I get these kind of errors in the console:

Timestamp: 11-05-2012 20:15:38
Error: TypeError: can't access dead object@@chrome://autopager/content/autopager-paging.js:1345
@chrome://autopager/content/autopager-paging.js:1265
@chrome://autopager/content/autopager-paging.js:1586
@chrome://autopager/content/autopager-paging.js:1569
@chrome://autopager/content/splitbrowse.js:596

Source File: chrome://autopager/content/autopager-bw-utils.js
Line: 225
Comment 3 Nicholas Nethercote [:njn] 2012-08-29 20:26:59 PDT
I'm also getting "TypeError: can't access dead object" messages, which indicates that the change in bug 695480 is having an effect, which has the side-effect of breaking the autopaging functionality.  That's a shame, but the add-on author is going to have to work around it.

Given that the zombie compartment no longer reproduces, we can close this bug report.
Comment 4 Jakob 2012-09-05 02:30:02 PDT
With version 0.7.1.6 I'm still getting errors in the console, but the functionality seems to be working, I can autopage on several pages. This is with Firefox 15.

Note You need to log in before you can comment on or make changes to this bug.