[SeaMonkey, Linux] "TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug674861.html | application timed out after 330 seconds with no output", caused by test_bug674770-2.html silently failing and leaking

VERIFIED FIXED in Firefox 12

Status

()

P2
major
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

(Blocks: 1 bug)

Trunk
mozilla13
x86
Linux
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox11 wontfix, firefox12 verified)

Details

(Whiteboard: [perma-orange] [test which aborts the suite], URL)

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Aurora/1330671985.1330675525.1946.gz&fulltext=1
WINNT 5.2 comm-aurora debug test mochitests-3/5 on 2012/03/01 23:06:25
is clean.


http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1330828139.1330832143.12450.gz&fulltext=1
Linux comm-central-trunk debug test mochitests-3/5 on 2012/03/03 18:28:59
{
[...]

15972 INFO TEST-PASS | /tests/editor/libeditor/html/tests/test_bug674770-2.html | failed to initialize at runBodyEditableDocumentTests2 - body:<span id="span" contenteditable="false">non-editable</span> should equal body:<span id="span" contenteditable="false">non-editable</span>

JavaScript strict warning: resource:///components/nsSearchService.js, line 2567: reference to undefined property cache.directories

15973 INFO TEST-PASS | /tests/editor/libeditor/html/tests/test_bug674770-2.html | pasted when middle clicked in non-editable element - body:<span id="span" contenteditable="false">non-editable</span> should equal body:<span id="span" contenteditable="false">non-editable</span>

Error loading URL http://pasted/ : 804b001e (NS_ERROR_UNKNOWN_HOST)

15974 INFO TEST-END | /tests/editor/libeditor/html/tests/test_bug674770-2.html | finished in 15197ms

15975 INFO TEST-START | /tests/editor/libeditor/html/tests/test_bug674861.html

Document http://www.pasted.com/ loaded successfully

TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug674861.html | application timed out after 330 seconds with no output

SCREENSHOT: data:image/png;base64,[...]
}

The screenshot shows SeaMonkey is stuck on loaded http://www.pasted.com/ :-<

Obviously, this URL should not be loaded at all:
I guess something wrong is happening with setting focus or the like...
(Assignee)

Comment 1

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Aurora/1330832235.1330835567.17787.gz&fulltext=1
Linux comm-aurora debug test mochitests-3/5 on 2012/03/03 19:37:15
+
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Beta/1330554956.1330557862.10358.gz
Linux comm-beta debug test mochitests-3/5 on 2012/02/29 14:35:56

are already affected.

Comment 2

7 years ago
The test also needs to set middlemouse.contentLoadURL to false.
(Assignee)

Updated

7 years ago
Assignee: nobody → sgautherie.bz
Blocks: 674770
Status: NEW → ASSIGNED
(Assignee)

Comment 3

7 years ago
Created attachment 602737 [details] [diff] [review]
(Av1) test_bug674770-2.html: Set "middlemouse.contentLoadURL" preference too
[Checked in: Comments 6 and 9]

This preference defaults to true on Unix (and Android).

(Untested.)

PS: I wonder why Firefox is not affected. Anyway...
Attachment #602737 - Flags: review?(ehsan)

Comment 4

7 years ago
Try run for 63f95380f65c is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=63f95380f65c
Results (out of 30 total builds):
    exception: 1
    success: 28
    warnings: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/sgautherie.bz@free.fr-63f95380f65c
(Assignee)

Comment 5

7 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #3)
> (Untested.)

(In reply to Mozilla RelEng Bot from comment #4)
>     https://tbpl.mozilla.org/?tree=Try&rev=63f95380f65c

Succeeded.

Updated

7 years ago
Attachment #602737 - Flags: review?(ehsan) → review+
(Assignee)

Comment 6

7 years ago
Comment on attachment 602737 [details] [diff] [review]
(Av1) test_bug674770-2.html: Set "middlemouse.contentLoadURL" preference too
[Checked in: Comments 6 and 9]

https://hg.mozilla.org/mozilla-central/rev/fa09b0296b3c


[Approval Request Comment]
Regression caused by (bug #): Bug 674770.
User impact if declined: None, but perma-orange (timeout + crash) on SeaMonkey.
Testing completed (on m-c, etc.): Comment 4 + this comment.
Risk to taking this patch (and alternatives if risky): None, test-only.
String changes made by this patch: None.
Attachment #602737 - Attachment description: (Av1) test_bug674770-2.html: Set "middlemouse.contentLoadURL" preference too → (Av1) test_bug674770-2.html: Set "middlemouse.contentLoadURL" preference too [Checked in: Comment 6]
Attachment #602737 - Flags: approval-mozilla-beta?
Attachment #602737 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED

Comment 7

7 years ago
Comment on attachment 602737 [details] [diff] [review]
(Av1) test_bug674770-2.html: Set "middlemouse.contentLoadURL" preference too
[Checked in: Comments 6 and 9]

[Triage Comment]
We try not to take any test changes at this point in the release in case it changes behavior and prevents us from recognizing a regression. Approving for Aurora 12, however.
Attachment #602737 - Flags: approval-mozilla-beta?
Attachment #602737 - Flags: approval-mozilla-beta-
Attachment #602737 - Flags: approval-mozilla-aurora?
Attachment #602737 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 8

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1331103356.1331105248.27168.gz&fulltext=1
Linux comm-central-trunk debug test mochitests-3/5 on 2012/03/06 22:55:56

V.Fixed
Status: RESOLVED → VERIFIED
status-firefox11: affected → wontfix
Keywords: checkin-needed
Whiteboard: [perma-orange] [test which aborts the suite] → [c-n: fa09b0296b3c to m-a] [perma-orange] [test which aborts the suite]
Comment on attachment 602737 [details] [diff] [review]
(Av1) test_bug674770-2.html: Set "middlemouse.contentLoadURL" preference too
[Checked in: Comments 6 and 9]

http://hg.mozilla.org/releases/mozilla-aurora/rev/2d7675fa0920
Attachment #602737 - Attachment description: (Av1) test_bug674770-2.html: Set "middlemouse.contentLoadURL" preference too [Checked in: Comment 6] → (Av1) test_bug674770-2.html: Set "middlemouse.contentLoadURL" preference too [Checked in: Comments 6 and 9]
status-firefox12: affected → fixed
Keywords: checkin-needed
Whiteboard: [c-n: fa09b0296b3c to m-a] [perma-orange] [test which aborts the suite] → [perma-orange] [test which aborts the suite]
(Assignee)

Comment 10

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Aurora/1331229534.1331231627.28109.gz
Linux comm-aurora debug test mochitests-3/5 on 2012/03/08 09:58:54

seamonkey2.9: verified.
status-firefox12: fixed → verified
You need to log in before you can comment on or make changes to this bug.