Firefox freezes for about 1 min 41 sec when switching to the Korean (ISO-2022-KR) encoding on http://www.sino.uni-heidelberg.de/dachs/intro.htm

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: nn.dm55, Unassigned)

Tracking

11 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120228210006

Steps to reproduce:

I clicked on a link which brought me to http://www.sino.uni-heidelberg.de/dachs/intro.htm , scrolled down to the part titled "Working routines", and noticed that the apostrophe in "China's" was a box character in the "UTF-8" encoding, so I clicked sequentially on each encoding in the first 3 menus under View->Character Encoding->More Encodings. When I clicked on Korean (ISO-2022-KR), which is the last one in the East Asian menu, Firefox stopped redrawing its window and didn't respond to keyboard or mouse input for about 1 minute and 41 seconds. While it was unresponsive, I clicked the "Close" button on the window. When Firefox started redrawing the window again, it asked me if I wanted to close all tabs. I clicked "Cancel" and then it froze again for approximately 35 seconds. After that, it was usable again. I restarted the browser and tried the same steps, and it froze the same way. I can reproduce this bug every time. This bug happens on Firefox 11.0 Beta 5 with a dual-core, 64-bit openSUSE Linux computer.


Actual results:

Firefox froze, gave me a dialog about whether I wanted to close all tabs, then froze again after I clicked "Cancel." Then Firefox thawed completely.


Expected results:

Firefox should have remained usable instead of freezing.
(Reporter)

Comment 1

6 years ago
I just tried the latest nightly and Firefox doesn't freeze anymore with these steps, so I'm closing this bug since it has already been fixed between the version I was using and the nightly version.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.