The add-on 'British English Dictionary' causes incremental garbage collection to be disabled.

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: wanderpost, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20120304 Firefox/13.0a1
Build ID: 20120304031031

Steps to reproduce:

Version: Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20120304 Firefox/13.0a1 ID:20120304031031

1. New Profile
2. install 'British English Dictionary' (v1.19.1)
3. check about:support or memchaser


Actual results:

Incremental GC is disabled.


Expected results:

Incremental GC is enabled.

This addon has 1,007,152 users (see AMO https://addons.mozilla.org/en-US/firefox/addon/british-english-dictionary/?src=ss). I seriously think this should be fixed before IGC goes public, otherwise a lot of people will be left out of this feature
(Reporter)

Comment 1

6 years ago
I have to undo this :)
I was testing this and while doing so I got the update for today and apparently it got fixed, because since the update I seem unable to reproduce this anymore.
(Reporter)

Comment 2

6 years ago
and I was doing some additional testing because it was more likely a combination of addons instead of this single one. But I'm marking it resolved now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

6 years ago
I'm sorry I will have to revise this yet again, I'm still seeing the issue.
But not specific related to this or that add-on or it is. Or it is related to a specific control but not consistently. I add here my about:support print: maybe this is already known, but from time to time it switches off, during surfing and then I close and reopen firefox and it is enabled again. I can't really follow what's going on here...


  Application Basics

        Name
        Firefox

        Version
        13.0a1

        User Agent
        Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20120305 Firefox/13.0a1

        Profile Folder

          Show Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

        Crash Reports

          about:crashes

        Memory Use

          about:memory

  Extensions

        Name

        Version

        Enabled

        ID

        About startup
        0.1.8
        true
        aboutstartup@glandium.org

        about:telemetry
        0.9.1
        true
        ping.telemetry@mozilla.com

        Adblock Plus
        2.0.3
        true
        {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

        Add-on Compatibility Reporter
        1.1
        true
        compatibility@addons.mozilla.org

        BetterPrivacy
        1.68
        true
        {d40f5e7b-d2cf-4856-b441-cc613eeffbe3}

        British English Dictionary
        1.19.1
        true
        en-GB@dictionaries.addons.mozilla.org

        Cache Status
        0.7.10
        true
        cache@status.org

        CS Lite Mod
        1.4.7
        true
        cslite-mod@wantora.bitbucket.org

        Cycle Collector Analyzer, about:ccdump
        0.4.1
        true
        ccdump@getfirebug.com

        DownloadHelper
        4.9.8
        true
        {b9db16a4-6edc-47ec-a1f4-b86292ed211d}

        FiddlerHook
        2.3.7.7
        true
        fiddlerhook@fiddler2.com

        Ghostery
        2.7.1
        true
        firefox@ghostery.com

        HTTPS Finder
        0.85
        true
        {6bdc61ae-7b80-44a3-9476-e1d121ec2238}

        HTTPS-Everywhere
        2.0development.6
        true
        https-everywhere@eff.org

        MemChaser
        0.2
        true
        memchaser@quality.mozilla.org

        Nightly Tester Tools
        3.2.1.1
        true
        {8620c15f-30dc-4dba-a131-7c5d20cf4a29}

        NoScript
        2.3.3rc2
        true
        {73a6fe31-595d-460b-a920-fcc0f8843232}

        RequestPolicy
        0.5.24b1
        true
        requestpolicy@requestpolicy.com

  Important Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.cache.disk.capacity
        1048576

        browser.cache.disk.smart_size.first_run
        false

        browser.cache.disk.smart_size_cached_value
        563200

        browser.cache.memory.capacity
        131072

        browser.history_expire_days.mirror
        180

        browser.places.importBookmarksHTML
        false

        browser.places.smartBookmarksVersion
        3

        browser.startup.homepage
        https://www.google.co.uk

        browser.startup.homepage_override.buildID
        20120305031045

        browser.startup.homepage_override.mstone
        13.0a1

        dom.ipc.plugins.unloadASAP
        true

        extensions.checkCompatibility
        false

        extensions.checkCompatibility.10.0
        false

        extensions.checkCompatibility.10.0a
        false

        extensions.checkCompatibility.11.0
        false

        extensions.checkCompatibility.11.0a
        false

        extensions.checkCompatibility.nightly
        false

        extensions.checkCompatibility.nightly.previous
        false

        extensions.checkCompatibility.previous
        false

        extensions.lastAppVersion
        13.0a1

        font.internaluseonly.changed
        true

        gfx.content.azure.enabled
        false

        gfx.font_rendering.directwrite.enabled
        true

        javascript.options.mem.log
        true

        network.cookie.cookieBehavior
        2

        network.cookie.prefsMigrated
        true

        network.dns.disablePrefetch
        true

        network.http.max-persistent-connections-per-proxy
        24

        network.prefetch-next
        false

        places.database.lastMaintenance
        1330940727

        places.history.expiration.transient_current_max_pages
        80511

        places.history.expiration.transient_optimal_database_size
        128817232

        places.last_vacuum
        1293811240

        privacy.cpd.downloads
        false

        privacy.cpd.history
        false

        privacy.donottrackheader.enabled
        true

        privacy.sanitize.migrateFx3Prefs
        true

        security.warn_viewing_mixed
        false

  Graphics

        Adapter Description
        NVIDIA GeForce 9500 GT

        Vendor ID
        0x10de

        Device ID
        0x0640

        Adapter RAM
        512

        Adapter Drivers
        nvd3dum nvwgf2um,nvwgf2um

        Driver Version
        8.17.12.8026

        Driver Date
        8-3-2011

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.1.7601.17563)

        ClearType Parameters
        ClearType parameters not found

        WebGL Renderer
        Google Inc. -- ANGLE (NVIDIA GeForce 9500 GT) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)

        GPU Accelerated Windows
        1/1 Direct3D 10

        AzureBackend
        direct2d

  JavaScript

        Incremental GC
        1
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Assignee: nobody → general
Component: Untriaged → JavaScript Engine
Product: Firefox → Core
Version: 13 Branch → unspecified

Comment 4

6 years ago
This is likely invalid, when it was first reported, EVERYTHING was causing iGC to be disabled.

As it stands, i cannot reproduce the reported issue in 15 or 16.
Thanks for testing!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.