config.cgi was broken by checkin for bug 731175

RESOLVED FIXED in Bugzilla 4.4

Status

()

Bugzilla
Bugzilla-General
--
major
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: gerv, Assigned: Frédéric Buclin)

Tracking

({regression})

Bugzilla 4.4
regression
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
On trunk, config.cgi (called without parameters) is giving errors of this type:

Software error:

Can't locate object method "match" via package "Bugzilla::Component" at Bugzilla/Product.pm line 115.

Binary search reveals the problem checkin to be 8141 (8140 works, 8141 doesn't), which is bug 731175. Although I have no idea how.

Gerv
(Assignee)

Updated

6 years ago
Severity: normal → major
Depends on: 731175
Keywords: regression
Target Milestone: --- → Bugzilla 4.4
Version: unspecified → 4.3
(Assignee)

Comment 1

6 years ago
Created attachment 602926 [details] [diff] [review]
patch, v1
Assignee: general → LpSolit
Status: NEW → ASSIGNED
Attachment #602926 - Flags: review?(dkl)
Comment on attachment 602926 [details] [diff] [review]
patch, v1

Review of attachment 602926 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. r=dkl
Attachment #602926 - Flags: review?(dkl) → review+
(Assignee)

Updated

6 years ago
Flags: approval+
(Assignee)

Comment 3

6 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/Product.pm
Committed revision 8145.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.