[d2c] Alternative Applications (such as Thunderbird)

VERIFIED FIXED in 6.4.8

Status

addons.mozilla.org Graveyard
Public Pages
P1
normal
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: gkoberger, Assigned: robhudson)

Tracking

unspecified
6.4.8

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
SHORT DESCRIPTION:

If we don't do compatibility checking (e.g. Thunderbird add-ons), add a link to the versions page that looks like this: http://cl.ly/063V3J3F2B252b281V18


LONGER RAMBLINGS:

Currently, applications like Thunderbird are hosted on AMO. We don't do any sort of compatibility checking anyway; we just show a download button. If the user is using a version of the application that isn't supported by the current add-on version (but is by another add-on version), they will download the add-on then think it doesn't work at all.

For example, let's say current version of Lightning doesn't work with Thunderbird 9, but the previous one did. Someone using Thunderbird 9 may assume that no versions work.

So, for add-ons that we don't do any compatibility checking on, we should add a message below indication what versions of the app the current version is available for. And, we should link to the versions page.

(Note: This is basically just bug 685685, however I felt it was easier for developers to not have to read that entire thread.)
(Reporter)

Updated

6 years ago
Duplicate of this bug: 685685
Assignee: nobody → robhudson.mozbugs
Target Milestone: --- → 6.4.6
Priority: -- → P1
(Assignee)

Comment 2

6 years ago
Are Firefox extensions the only thing we do compatibility checking on? So anything NOT firefox extensions would get this extra string + link?
(Reporter)

Comment 3

6 years ago
Whoops, I should clarify.

It should only do it for extensions (not themes, search, etc) where appsuported (in buttons.js) is false.

So, for example, Thunderbird extensions, where we show "Continue to Download": http://cl.ly/3i2M2N3I1M1I1L2t0A1B

I'm not sure the exact conditions; buttons.js is fairly confusing. Feel free to use your judgement -- if it seems like someone would benefit from a link to the versions page, add it.
Target Milestone: 6.4.6 → 6.4.8
(Assignee)

Comment 4

6 years ago
https://github.com/mozilla/zamboni/commit/181a1865
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 5

6 years ago
Verified as fixed in https://addons-dev.allizom.org/en-US/ on FF11
Attaching postfix screenshot for this issue.
Closing bug.
Status: RESOLVED → VERIFIED

Comment 6

6 years ago
Created attachment 614753 [details]
postfix other versions

Updated

3 years ago
Duplicate of this bug: 737217
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.