Closed Bug 733142 Opened 8 years ago Closed 8 years ago

crash [@ java.lang.RuntimeException: Unable to destroy activity {org.mozilla.fennec_aurora/org.mozilla.fennec_aurora.App}: java.lang.IllegalArgumentException: Receiver not registered: org.mozilla.gecko.GeckoNetworkManager@41951ab8: at android.app.Activity

Categories

(Firefox for Android :: General, defect, critical)

14 Branch
ARM
Android
defect
Not set
critical

Tracking

()

VERIFIED FIXED
Firefox 14
Tracking Status
firefox14 --- verified
firefox15 --- verified
blocking-fennec1.0 --- beta+

People

(Reporter: nhirata, Assigned: mounir)

References

Details

(Keywords: crash, regression, topcrash, Whiteboard: [native-crash])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-c47414b2-0dc4-4463-a93b-43eb12120303 .
============================================================= 
java.lang.RuntimeException: Unable to destroy activity {org.mozilla.fennec_aurora/org.mozilla.fennec_aurora.App}: java.lang.IllegalArgumentException: Receiver not registered: org.mozilla.gecko.GeckoNetworkManager@41951ab8
	at android.app.ActivityThread.performDestroyActivity(ActivityThread.java:3108)
	at android.app.ActivityThread.handleDestroyActivity(ActivityThread.java:3126)
	at android.app.ActivityThread.access$1200(ActivityThread.java:122)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1179)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:137)
	at org.mozilla.gecko.GeckoApp$32.run(GeckoApp.java:1777)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4340)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
	at dalvik.system.NativeStart.main(Native Method)
Caused by: java.lang.IllegalArgumentException: Receiver not registered: org.mozilla.gecko.GeckoNetworkManager@41951ab8
	at android.app.LoadedApk.forgetReceiverDispatcher(LoadedApk.java:628)
	at android.app.ContextImpl.unregisterReceiver(ContextImpl.java:1066)
	at android.content.ContextWrapper.unregisterReceiver(ContextWrapper.java:354)
	at org.mozilla.gecko.GeckoNetworkManager.stopListening(GeckoNetworkManager.java:178)
	at org.mozilla.gecko.GeckoNetworkManager.stop(GeckoNetworkManager.java:173)
	at org.mozilla.gecko.GeckoApp.onDestroy(GeckoApp.java:2171)
	at android.app.Activity.performDestroy(Activity.java:4629)
	at android.app.Instrumentation.callActivityOnDestroy(Instrumentation.java:1079)
	at android.app.ActivityThread.performDestroyActivity(ActivityThread.java:3095)
	... 15 more
OS: Linux → Android
Hardware: All → ARM
Version: Firefox 13 → Firefox 12
blocking-fennec1.0: --- → -
Duplicate of this bug: 735080
There were no crashes in 13.0a2 and 14.0a1 up to 14.0a1/20120322031220.
There are now 36 crashes making it #1 top crasher over the last day.
The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4bdae514b9be&tochange=5c13fce74f83
blocking-fennec1.0: - → ?
Keywords: regression, topcrash
Version: Firefox 12 → Firefox 14
Mounir - Any chance this you can take a look at this?
Assignee: nobody → mounir
blocking-fennec1.0: ? → beta+
I can't remember why I stop listening on onDestroy() given that it's done on onStop() too. However, Doug told me he knows what is happening but he was on a hurry so he did not tell me more.
Attached patch Patch v1Splinter Review
I have no idea why the crash stopped because I doubt they are actually fixed. One of my guess is that I could have caused some and I stopped testing those APIs. My other guess is involving dwarfs and elves...
Attachment #610209 - Flags: review?(doug.turner)
Its reappearance in 14.0a1 might be caused by bug 737392.

(In reply to Mounir Lamouri (:volkmar) (:mounir) from comment #5)
> My other guess is involving dwarfs and elves...
I added the illustrious Copperfield to the CCs for an explanation.
Whatever the reasons of the crash could be, the only thing that could be wrong here is if we try to call stop() twice will enableNotifications() has been called. In that case, the second call will crash. GeckoNetworkManager hasn't been designed for that. Given that onDestroy() can't be called without onStop() being called, we can safely remove the call for stop() in onDestroy(). I believe.
Comment on attachment 610209 [details] [diff] [review]
Patch v1

Review of attachment 610209 [details] [diff] [review]:
-----------------------------------------------------------------

lets give it a go
Attachment #610209 - Flags: review?(doug.turner) → review+
Target Milestone: --- → Firefox 14
https://hg.mozilla.org/mozilla-central/rev/82c98e0e7d71
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 740602
I cannot reproduce this crash either on Nightly or Aurora. Closing bug as verified fixed.

--
Firefox 15.0a1 (2012-05-02), Firefox 14.0a2 (2012-05-01)
Device: Samsung Captivate
OS: Android 2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.