Closed Bug 733153 Opened 8 years ago Closed 7 years ago

Remove old widget.ime.android.landscape_fullscreen/fullscreen_threshold settings

Categories

(Firefox for Android :: Keyboards and IME, defect, P5, minor)

ARM
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 847823

People

(Reporter: cpeterson, Assigned: cpeterson)

References

Details

Attachments

(1 file, 3 obsolete files)

ibarlow says:

> Since we're moving away from using the full-screen keyboard and large input box 
> model in landscape mode, it makes sense to present users with the same 
> interaction they would experience in portrait mode:

Now that the Java code is moving away from ever using the fullscreen keyboard, we won't need mobile.js' "widget.ime.android.landscape_fullscreen" or "widget.ime.android.fullscreen_threshold" settings or the Java code that reads those settings.
Assignee: nobody → cpeterson
Depends on: 733196
Remove obsolete widget.ime.android.landscape_fullscreen and fullscreen_threshold prefs.
Attachment #603120 - Flags: review?(doug.turner)
Status: NEW → ASSIGNED
Attachment #603120 - Flags: review?(doug.turner) → review+
Keywords: checkin-needed
This is more bitrotted than I want to try fixing on my own. Please rebase and re-upload.
Keywords: checkin-needed
Rebased patch. Carry forward r=dougt.
Attachment #603120 - Attachment is obsolete: true
Attachment #603922 - Flags: review+
Keywords: checkin-needed
Blocks: 733196
No longer depends on: 733196
Sorry, we had to back this out on inbound because it broke XUL fennec:
https://hg.mozilla.org/integration/mozilla-inbound/rev/64a62f199dbd
Patch v4 fix try server break by removing landscape_fullscreen pref from XUL Fennec, too.
Attachment #603922 - Attachment is obsolete: true
Attachment #604471 - Flags: review?(doug.turner)
Component: General → IME
QA Contact: general → ime
Comment on attachment 604471 [details] [diff] [review]
bug-733153-remove-fullscreen-prefs-v4.patch

Do not use fullscreen keyboard in landscape mode (Native and XUL Fennec).
Attachment #604471 - Flags: review?(doug.turner) → review?(blassey.bugs)
Comment on attachment 604471 [details] [diff] [review]
bug-733153-remove-fullscreen-prefs-v4.patch

don't change xul fennec
Attachment #604471 - Flags: review?(blassey.bugs) → review-
Don't use fullscreen keyboard when Native Fennec is in landscape orientation.

XUL Fennec will continue to use fullscreen keyboard. I still need to change XUL Fennec's notifyIMEEnabled() method signature because it is called from JNI code that is shared by Native and XUL Fennec.
Attachment #604471 - Attachment is obsolete: true
Attachment #605489 - Flags: review?(blassey.bugs)
Comment on attachment 605489 [details] [diff] [review]
bug-733153-remove-fullscreen-keyboard-v5.patch

Review of attachment 605489 [details] [diff] [review]:
-----------------------------------------------------------------

you are still changing the behavior of XUL fennec, just in the opposite direction now

::: mobile/android/base/GeckoInputConnection.java
@@ +750,5 @@
>          else if (mIMEActionHint != null && mIMEActionHint.length() != 0)
>              outAttrs.actionLabel = mIMEActionHint;
>  
> +        outAttrs.imeOptions |= EditorInfo.IME_FLAG_NO_EXTRACT_UI;
> +        if (VERSION.SDK_INT >= 11) { // Honeycomb

s/11/VERSION_CODES.HONEYCOMB

@@ +751,5 @@
>              outAttrs.actionLabel = mIMEActionHint;
>  
> +        outAttrs.imeOptions |= EditorInfo.IME_FLAG_NO_EXTRACT_UI;
> +        if (VERSION.SDK_INT >= 11) { // Honeycomb
> +            outAttrs.imeOptions |= EditorInfo.IME_FLAG_NO_FULLSCREEN;

why not include this flag unconditionally? pre-honeycomb should just ignore it. (please test this theory before landing)
Attachment #605489 - Flags: review?(blassey.bugs) → review-
No longer blocks: 733196
Depends on: 733196
Status: ASSIGNED → NEW
Target Milestone: --- → Firefox 15
Priority: -- → P5
Target Milestone: Firefox 15 → ---
I'm getting rid of these prefs as part of code clean up in Bug 847823. I think we are okay with breaking XUL now that there's nothing to break :)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 847823
You need to log in before you can comment on or make changes to this bug.