If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Install button will not shown for some add-ons if we see the page with Firefox for Android.

RESOLVED FIXED in 2013-01-10

Status

addons.mozilla.org Graveyard
Public Pages
P2
normal
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: dynamis (Tomoya ASAI), Assigned: cvan)

Tracking

unspecified
2013-01-10
ARM
Android

Details

(Whiteboard: u=patron p=)

(Reporter)

Description

6 years ago
On some add-on pages, Install button (green, blue or gray) will not shown when we see the page with Android Firefox.
# confirmed with Android Firefox 10 & 11 beta

examples and screenshots:
https://addons.mozilla.org/ja/mobile/addon/cybertrust-deviceid-importer/
https://skitch.com/dynamis/88qf7/device-screen-capture
https://addons.mozilla.org/ja/mobile/addon/cert-manager/
https://skitch.com/dynamis/88qfw/device-screen-capture

Install button should be shown.

Note: if we search these add-ons in the "Get Add-ons" search box in the pref, install button will be shown and correctly installed.

Comment 1

5 years ago
I also ran into the same problem.

In my environment, the installation button seems to be visible form a tablet but invisible from a smartphone.

Steps to reproduce
1) Open Firefox for Android (17.0 ~ 20.0a) on a tablet like Nexus 7.
2) Visit https://addons.mozilla.org/en-US/firefox/addon/fennec-location-bar/
3) Can't find the download link (a green button).

But when I visited the URL from my smartphone, the download link worked well.
Some other add-ons for Android are also the same.

I confirmed the issue on Galaxy SII SC-02C and Nexus 7 32GB with Firefox for Android 17, 18 and 20
(Assignee)

Comment 2

5 years ago
Can I get your user-agents?

Comment 3

5 years ago
(In reply to Chris Van Wiemeersch [:cvan] from comment #2)
> Can I get your user-agents?

Nexus 7, Firefox Beta 18.0
Mozilla/5.0 (Android; Tablet; rv:18.0) Gecko/18.0 Firefox/18.0

Galaxy SII SC-02C
Mozilla/5.0 (Android; Mobile; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (Android; Mobile; rv:20.0) Gecko/20.0 Firefox/20.0

# I used this site, http://www.openspc2.org/JavaScript/library/system/useragent/index.html
# I don't change the user-agent with an add-on.
(Assignee)

Updated

5 years ago
Assignee: nobody → cvan
Target Milestone: --- → 2013-01-03
(Assignee)

Updated

5 years ago
Target Milestone: 2013-01-03 → 2013-01-10
p2 to figure out what is going on.  unknown how long it will take
Priority: -- → P2
Whiteboard: u=patron p=
(Assignee)

Comment 5

5 years ago
You're viewing this on a desktop? Or is your tablet serving you the desktop version instead of the mobile version?
(Assignee)

Comment 6

5 years ago
https://github.com/mozilla/zamboni/commit/ee05917
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.