XUL fails and/or crashes silently if file not found

VERIFIED DUPLICATE of bug 7401

Status

()

P3
major
VERIFIED DUPLICATE of bug 7401
20 years ago
11 years ago

People

(Reporter: pierre, Assigned: hyatt)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
We just fixed a crasher in the optimized builds of the M6 branch due to missing
aliases in the dist directory: navigator.xul was trying to open contentframe.xul
which was missing.

It's not the first time that this kind of bug happens. People forget to update
the MakeFile or Manifest files and we end up with a crasher at startup which is
often quite difficult to locate.

We need to report the error to the user when a necessary file can't be opened.

Updated

20 years ago
Assignee: trudelle → hyatt

Comment 1

20 years ago
reassigning to hyatt
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

20 years ago
Dup of 7401

*** This bug has been marked as a duplicate of 7401 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 3

20 years ago
Verified Dup 06.16.99

Comment 4

19 years ago
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL

Updated

11 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: ckritzer → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.